aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kine/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kine/APKBUILD')
-rw-r--r--testing/kine/APKBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/testing/kine/APKBUILD b/testing/kine/APKBUILD
index 1ac12748971..27177592516 100644
--- a/testing/kine/APKBUILD
+++ b/testing/kine/APKBUILD
@@ -1,19 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=kine
-pkgver=0.5.1
-pkgrel=2
+pkgver=0.10.1
+pkgrel=4
pkgdesc="etcd API with sqlite, Postgres, Mysql, or dqlite backed"
-url="https://github.com/rancher/kine"
-arch="all !mips !mips64"
+url="https://github.com/k3s-io/kine"
+arch="all"
license="Apache-2.0"
makedepends="sqlite-dev go"
subpackages="$pkgname-doc"
options="!check" # no testsuite
-source="$pkgname-$pkgver.tar.gz::https://github.com/rancher/kine/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/k3s-io/kine/archive/v$pkgver.tar.gz"
provides="etcd-api"
+provider_priority=1
+
+export GOFLAGS="$GOFLAGS -tags=libsqlite3"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build -v -ldflags="-w -s" .
+ go build -v .
}
package() {
@@ -21,4 +27,6 @@ package() {
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/kine/LICENSE
}
-sha512sums="0eb5bbfd473fc0a656f0592e655fffd23b83277c3d1f3e6e338f2362b1e168dbf497c503f013a4b56cf2bd1fe5b95f74024ee53bc452765799cc903c12a2df59 kine-0.5.1.tar.gz"
+sha512sums="
+01b94a0ede751d03ef91c8a33be65fc95212147cec5df7eecbb6b6b35af0d1f002abed6c22caedeea38c13f5422b8385d5d7d8ff1d5ade9046964e0a30eec5f7 kine-0.10.1.tar.gz
+"