aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kodi-pvr-iptvsimple/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kodi-pvr-iptvsimple/APKBUILD')
-rw-r--r--testing/kodi-pvr-iptvsimple/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/testing/kodi-pvr-iptvsimple/APKBUILD b/testing/kodi-pvr-iptvsimple/APKBUILD
index 0fa6ed10f73..bf097608287 100644
--- a/testing/kodi-pvr-iptvsimple/APKBUILD
+++ b/testing/kodi-pvr-iptvsimple/APKBUILD
@@ -1,31 +1,30 @@
# Contributor: Damian Kurek <starfire24680@gmail.com>
# Maintainer: Damian Kurek <starfire24680@gmail.com>
pkgname=kodi-pvr-iptvsimple
-pkgver=7.6.10
-_realname=Matrix
+pkgver=20.11.0
+_realname=Nexus
pkgrel=0
pkgdesc="IPTV Simple client addon for Kodi"
options="!check" # no test suite
url="https://github.com/kodi-pvr/pvr.iptvsimple"
-arch="x86 x86_64 aarch64 armv7" # kodi is only available on those architectures
+arch="x86_64 aarch64 armv7" # kodi is available only on these architectures
license="GPL-2.0-only"
-makedepends="cmake kodi-dev"
+makedepends="cmake kodi-dev samurai"
source="$pkgname-$pkgver-$_realname.tar.gz::https://github.com/kodi-pvr/pvr.iptvsimple/archive/$pkgver-$_realname.tar.gz"
builddir="$srcdir/pvr.iptvsimple-$pkgver-$_realname"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_MODULE_PATH=/usr/lib/cmake/kodi \
- -DUSE_LTO=1
+ -DCMAKE_MODULE_PATH=/usr/lib/cmake/kodi
cmake --build build
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-76c8ab57e5341b3c7c9324560337c6f7d8f9fce5902f6277ea40e420eefa71d39f9904eb513ea2ae9ff2153a15ca22545e65cbbdf0044e171a15ee50cbd96750 kodi-pvr-iptvsimple-7.6.10-Matrix.tar.gz
+052da2a550c7264f396a64277bffd068d6fbfc1eb252c8270e3b2846a856d642a1d45f69a2115db528a8654afa377316ee9153907afbf6be1a630d581621bea5 kodi-pvr-iptvsimple-20.11.0-Nexus.tar.gz
"