aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lablgtk
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lablgtk')
-rw-r--r--testing/lablgtk/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/testing/lablgtk/APKBUILD b/testing/lablgtk/APKBUILD
index 949677a2d76..4da685341e8 100644
--- a/testing/lablgtk/APKBUILD
+++ b/testing/lablgtk/APKBUILD
@@ -11,25 +11,25 @@ depends_dev="lablgtk"
depends="ocaml-findlib camlp4 ocaml gtk+-dev gtkspell-dev librsvg-dev
gtksourceview2-dev"
makedepends="$depends"
-install=""
subpackages="$pkgname-doc $pkgname-dev"
source="https://forge.ocamlcore.org/frs/download.php/1627/lablgtk-$pkgver.tar.gz"
builddir="$srcdir/lablgtk-$pkgver"
build() {
cd "$builddir"
+
./configure --prefix=/usr || return 1
make world || return 1
make opt || return 1
make doc || return 1
}
-
doc() {
- pkgdesc="$pkgdesc (documentation)"
- _docdir="$subpkgdir"/usr/share/doc/$pkgname/
- mkdir -p "$_docdir"
- cp -r "$builddir"/doc/html/* "$_docdir"
+ pkgdesc="$pkgdesc (documentation)"
+
+ local docdir="$subpkgdir"/usr/share/doc/$pkgname/
+ mkdir -p "$docdir"
+ cp -r "$builddir"/doc/html/* "$docdir"/
}
package() {