aboutsummaryrefslogtreecommitdiffstats
path: root/testing/laminar/laminard-location.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/laminar/laminard-location.patch')
-rw-r--r--testing/laminar/laminard-location.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/testing/laminar/laminard-location.patch b/testing/laminar/laminard-location.patch
new file mode 100644
index 00000000000..6566ade866e
--- /dev/null
+++ b/testing/laminar/laminard-location.patch
@@ -0,0 +1,13 @@
+Install laminard under bin.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -142,7 +142,7 @@ endif()
+ set(SYSTEMD_UNITDIR /lib/systemd/system CACHE PATH "Path to systemd unit files")
+ set(BASH_COMPLETIONS_DIR /usr/share/bash-completion/completions CACHE PATH "Path to bash completions directory")
+ set(ZSH_COMPLETIONS_DIR /usr/share/zsh/site-functions CACHE PATH "Path to zsh completions directory")
+-install(TARGETS laminard RUNTIME DESTINATION sbin)
++install(TARGETS laminard RUNTIME DESTINATION bin)
+ install(TARGETS laminarc RUNTIME DESTINATION bin)
+ install(FILES etc/laminar.conf DESTINATION /etc)
+ install(FILES etc/laminarc-completion.bash DESTINATION ${BASH_COMPLETIONS_DIR} RENAME laminarc)