aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libbpf
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libbpf')
-rw-r--r--testing/libbpf/30-include-bits-reg.patch12
-rw-r--r--testing/libbpf/APKBUILD10
2 files changed, 18 insertions, 4 deletions
diff --git a/testing/libbpf/30-include-bits-reg.patch b/testing/libbpf/30-include-bits-reg.patch
new file mode 100644
index 00000000000..fc3521a1602
--- /dev/null
+++ b/testing/libbpf/30-include-bits-reg.patch
@@ -0,0 +1,12 @@
+diff --git a/src/hashmap.h b/src/hashmap.h
+index 03748a7..e83055e 100644
+--- a/src/hashmap.h
++++ b/src/hashmap.h
+@@ -10,4 +10,5 @@
+
+ #include <stdbool.h>
+ #include <stddef.h>
++#include <bits/reg.h>
+ #include "libbpf_internal.h"
+
+ static inline size_t hash_bits(size_t h, int bits)
diff --git a/testing/libbpf/APKBUILD b/testing/libbpf/APKBUILD
index 201d5c04e9c..dad48f3f2ab 100644
--- a/testing/libbpf/APKBUILD
+++ b/testing/libbpf/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adam Jensen <acjensen@gmail.com>
pkgname=libbpf
-pkgver=0.0.3
+pkgver=0.0.4
pkgrel=0
pkgdesc="A library for interacting with the Linux kernel's Berkeley Packet Filter (BPF) facility from user space"
url="https://github.com/libbpf/libbpf"
@@ -13,7 +13,8 @@ makedepends="build-base linux-headers elfutils-dev"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
10-include-stddef.patch
- 20-trailing-ldflags.patch"
+ 20-trailing-ldflags.patch
+ 30-include-bits-reg.patch"
build() {
cd src
@@ -26,6 +27,7 @@ package() {
cp -R "$builddir/include/uapi" "$pkgdir/usr/include/uapi"
}
-sha512sums="ee489d968cd9a20a1f091dcd2696d3807ab0db2a001613684402de2c696391eea033f3bd961eaf1d0df95c1e15f4f0ccfb7003ff98c3f08f24a7e9a8db22cdad libbpf-0.0.3.tar.gz
+sha512sums="1e4a16ed0f3e378aa9d7080e4b54cb3a9542975105b09977d1ddecf3ae4dabb3b5edf80b92b61644b1f0cbda7ee7e135ee0f736e71c1d201a97b1b3dd573b543 libbpf-0.0.4.tar.gz
946e445ffa4c5df42ebac77b7a1c6478b37dc7b55e0883aee195c6a8c4f8718b4dbf98b7c6d3016e1619e59440d8e4a76dad1e843114dfe2f9a2610e5cbb7943 10-include-stddef.patch
-1ec15c45fc085b44aa1f6d5626f0ba9e57280304d1f6e1c4e7fe8e2b81fc927f5500fd48f8e70d2affb91dd67a74a80c85698d39bb85febde5abd479df5cdccc 20-trailing-ldflags.patch"
+1ec15c45fc085b44aa1f6d5626f0ba9e57280304d1f6e1c4e7fe8e2b81fc927f5500fd48f8e70d2affb91dd67a74a80c85698d39bb85febde5abd479df5cdccc 20-trailing-ldflags.patch
+27cfd7799bad695e5a1b949cfa12fd37f13d01256f4cc19a990a7c8cc2786d429f7ec6d99c6eea1ab48590662b6769f9d814fcb343de61f3e222a7a68a751876 30-include-bits-reg.patch"