aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libcotp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libcotp/APKBUILD')
-rw-r--r--testing/libcotp/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/libcotp/APKBUILD b/testing/libcotp/APKBUILD
index 78a6e1df3f1..a0a5f8fcb63 100644
--- a/testing/libcotp/APKBUILD
+++ b/testing/libcotp/APKBUILD
@@ -1,19 +1,19 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=libcotp
-pkgver=1.2.3
+pkgver=2.0.2
pkgrel=0
pkgdesc="Library for generating TOTP and HOTP"
url="https://github.com/paolostivanin/libcotp"
license="Apache-2.0"
arch="all"
-options="!check" # needs criterion
-makedepends="cmake libgcrypt-dev libbaseencode-dev"
+makedepends="cmake libgcrypt-dev samurai"
subpackages="$pkgname-dev"
source="https://github.com/paolostivanin/libcotp/archive/v$pkgver/libcotp-$pkgver.tar.gz"
+options="!check" # needs criterion
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -24,4 +24,6 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="a7c78bf04955f0be6bb5abb2a2616306f1a3b3f02b5e396833ffff3d1bac65e683512b77acc2b45f8eb0f5d16c2088040911e3f1ee18a6cb3c1604b3970cefe4 libcotp-1.2.3.tar.gz"
+sha512sums="
+c630ba7787aef66cdd8bf5dad8b439165795a6c875a850b6ffc4462a1f414c4d81a7db784831f68ec7fce6c9f393fd857cb84afb0c63527a5b4be85ca14896d9 libcotp-2.0.2.tar.gz
+"