aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libfm-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libfm-qt/APKBUILD')
-rw-r--r--testing/libfm-qt/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/libfm-qt/APKBUILD b/testing/libfm-qt/APKBUILD
deleted file mode 100644
index a902b0d625b..00000000000
--- a/testing/libfm-qt/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
-pkgname=libfm-qt
-pkgver=1.0.0
-pkgrel=0
-pkgdesc="Qt port of libfm"
-url="https://github.com/lxqt/libfm-qt"
-arch="all !s390x !mips !mips64" # s390x, mips, mips64 blocked by libfm
-license="LGPL-2.0-or-later"
-makedepends="
- cmake lxqt-build-tools qt5-qtx11extras-dev qt5-qttools-dev
- menu-cache-dev libexif-dev libfm-dev qt5-qtbase-dev
- "
-subpackages="$pkgname-dev"
-options="!check" # No testsuite
-source="https://github.com/lxqt/libfm-qt/releases/download/$pkgver/libfm-qt-$pkgver.tar.xz"
-
-build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- $CMAKE_CROSSOPTS .
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-sha512sums="
-8609709b00a67273e4cb3ca18ad695df172ff3cac2ed70d48e5f607c20a4d4507598b500957bf197bffa65db4ad5843f3fd477a56868c95507a594542f24b5b4 libfm-qt-1.0.0.tar.xz
-"