aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libfyaml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libfyaml/APKBUILD')
-rw-r--r--testing/libfyaml/APKBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/testing/libfyaml/APKBUILD b/testing/libfyaml/APKBUILD
index 2223121107e..d1ac2689ac9 100644
--- a/testing/libfyaml/APKBUILD
+++ b/testing/libfyaml/APKBUILD
@@ -1,23 +1,16 @@
# Contributor: Lucas Ramage <ramage.lucas@protonmail.com>
# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
pkgname=libfyaml
-pkgver=0.7
+pkgver=0.9
pkgrel=0
pkgdesc="Fully feature complete YAML parser and emitter"
url="https://github.com/pantoniou/libfyaml"
arch="all"
license="MIT"
-depends="libltdl"
+makedepends="bash libtool linux-headers m4"
checkdepends="check git"
-makedepends="autoconf automake bash libtool"
-subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/pantoniou/libfyaml/archive/refs/tags/v$pkgver.tar.gz"
-options="!check" # tests failing, (See: https://github.com/pantoniou/libfyaml/issues/20)
-
-prepare() {
- default_prepare
- ./bootstrap.sh
-}
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/pantoniou/libfyaml/releases/download/v$pkgver/libfyaml-$pkgver.tar.gz"
build() {
./configure \
@@ -40,4 +33,6 @@ check() {
make check
}
-sha512sums="748e483f456ac17765e41f48fe977c99cd16141ac1e146096b67df817b414e00a40dc5fe410fa4a1f31e63cc6f6d839698514980916e84f838dd3e4f1a947221 libfyaml-0.7.tar.gz"
+sha512sums="
+95979361ed50a46acc6da698e4750562f6e3e46aa5d050180225d93afb74929981d9c1d1ca3b6a77fe21a1546a68a9e3df17cdfef5f93257ad5d0c7ad03ae2eb libfyaml-0.9.tar.gz
+"