aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libgnt
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libgnt')
-rw-r--r--testing/libgnt/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/libgnt/APKBUILD b/testing/libgnt/APKBUILD
new file mode 100644
index 00000000000..a4b9b2cb853
--- /dev/null
+++ b/testing/libgnt/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=libgnt
+pkgver=2.14.0
+pkgrel=0
+pkgdesc="glib ncurses toolkit"
+url="https://bitbucket.org/pidgin/libgnt/"
+arch="all"
+license="GPL-2.0-or-later"
+depends="!finch<=2.13.0"
+makedepends="meson glib-dev libxml2-dev ncurses-dev gtk-doc"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/project/pidgin/libgnt/$pkgver/libgnt-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=plain \
+ . output
+ ninja -C output
+}
+
+check() {
+ # Replace with proper check command(s)
+ :
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="0d9c5550374696a0e6ede5246cda3c372d7055d21b9ffaf10be88d6a469bdf18c7dd1113ec612acf4889c0e5686ea87bb0e8348ca8985fd5ff8913afc5813b38 libgnt-2.14.0.tar.xz"