aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libideviceactivation/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libideviceactivation/APKBUILD')
-rw-r--r--testing/libideviceactivation/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/libideviceactivation/APKBUILD b/testing/libideviceactivation/APKBUILD
new file mode 100644
index 00000000000..1e3b0925e7d
--- /dev/null
+++ b/testing/libideviceactivation/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Kasper K <kasperkantz@outlook.com>
+# Maintainer: Kasper K <kasperkantz@outlook.com>
+pkgname=libideviceactivation
+pkgver=1.1.1
+pkgrel=4
+pkgdesc="Library to handle the activation process of iOS devices"
+url="https://libimobiledevice.org"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="libimobiledevice-dev curl-dev libxml2-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/libimobiledevice/libideviceactivation/releases/download/$pkgver/libideviceactivation-$pkgver.tar.bz2"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+72d6e7024404d1a45e419ccdb7603268a1d96845c8636696b55d2c6edd3177b881ef0f5bd7aea548e88ef7976c83fbac63d3c3d7a9b76eba83de492c269ab02a libideviceactivation-1.1.1.tar.bz2
+"