aboutsummaryrefslogtreecommitdiffstats
path: root/testing/liblxqt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/liblxqt/APKBUILD')
-rw-r--r--testing/liblxqt/APKBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/testing/liblxqt/APKBUILD b/testing/liblxqt/APKBUILD
deleted file mode 100644
index f13986ae716..00000000000
--- a/testing/liblxqt/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
-pkgname=liblxqt
-pkgver=0.16.0
-pkgrel=0
-pkgdesc="Common base library for LXQt components"
-url="https://github.com/lxqt/liblxqt"
-arch="all !armhf" # armhf blocked by kwindowsystem"
-arch="$arch !mips !mips64" # mips(64) blocked by polkit-elogind
-license="LGPL-2.0-or-later"
-makedepends="
- cmake
- lxqt-build-tools
- qt5-qttools-dev
- libqtxdg-dev
- kwindowsystem-dev
- qt5-qtx11extras-dev
- libxscrnsaver-dev
- "
-subpackages="$pkgname-dev"
-source="https://github.com/lxqt/liblxqt/releases/download/$pkgver/liblxqt-$pkgver.tar.xz"
-options="!check" # No testsuite
-
-# Enable backlight support when possible
-case "$CARCH" in
- s390x) ;;
- *) makedepends="$makedepends polkit-qt-1-dev" ;;
-esac
-
-build() {
- # Requires polkit-qt-1-dev which requires polkit
- # which is not available on rust-less arches like
- # s390x
- case "$CARCH" in
- s390x) _build_backlight=OFF ;;
- *) _build_backlight=ON ;;
- esac
-
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DBUILD_BACKLIGHT_LINUX_BACKEND=$_build_backlight \
- $CMAKE_CROSSOPTS .
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-
-sha512sums="ef44d046b5c3fe40ee528a9565964814656507395585cc2df4a7debd735bcc81b6e76ed9f91fb846504104182e74b037cbea0c6beecb41ce0003f811f1dd887d liblxqt-0.16.0.tar.xz"