aboutsummaryrefslogtreecommitdiffstats
path: root/testing/liblxqt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/liblxqt/APKBUILD')
-rw-r--r--testing/liblxqt/APKBUILD57
1 files changed, 0 insertions, 57 deletions
diff --git a/testing/liblxqt/APKBUILD b/testing/liblxqt/APKBUILD
deleted file mode 100644
index 6ca4a561be9..00000000000
--- a/testing/liblxqt/APKBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
-pkgname=liblxqt
-pkgver=1.0.0
-pkgrel=0
-pkgdesc="Common base library for LXQt components"
-url="https://github.com/lxqt/liblxqt"
-# armhf blocked by extra-cmake-modules -> kwindowsystem
-arch="all !armhf"
-license="LGPL-2.0-or-later"
-makedepends="
- cmake
- lxqt-build-tools
- qt5-qttools-dev
- libqtxdg-dev
- kwindowsystem-dev
- qt5-qtx11extras-dev
- libxscrnsaver-dev
- "
-subpackages="$pkgname-dev"
-source="https://github.com/lxqt/liblxqt/releases/download/$pkgver/liblxqt-$pkgver.tar.xz"
-options="!check" # No testsuite
-
-# Enable backlight support when possible
-case "$CARCH" in
- s390x|mips64|riscv64) ;;
- *) makedepends="$makedepends polkit-qt-1-dev" ;;
-esac
-
-build() {
- # Requires polkit-qt-1-dev which requires polkit
- # which is not available on rust-less arches like
- # s390x
- case "$CARCH" in
- s390x|mips64|riscv64) _build_backlight=OFF ;;
- *) _build_backlight=ON ;;
- esac
-
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DBUILD_BACKLIGHT_LINUX_BACKEND=$_build_backlight \
- $CMAKE_CROSSOPTS
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-9b0c081f644285e929f73a2a3aeb051383432ff353f918d4f8cbe57d2f5f330ab7b29329dcc17dd3605fe0904005b1c5009be77ee5ac6e2739b8baaf0fadaa5b liblxqt-1.0.0.tar.xz
-"