aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libreoffice
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libreoffice')
-rw-r--r--testing/libreoffice/APKBUILD194
-rw-r--r--testing/libreoffice/fix-execinfo.patch24
-rw-r--r--testing/libreoffice/fix-includes.patch31
-rw-r--r--testing/libreoffice/linux-musl.patch68
4 files changed, 317 insertions, 0 deletions
diff --git a/testing/libreoffice/APKBUILD b/testing/libreoffice/APKBUILD
new file mode 100644
index 00000000000..9b78c5295ca
--- /dev/null
+++ b/testing/libreoffice/APKBUILD
@@ -0,0 +1,194 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer:
+pkgname=libreoffice
+pkgver=4.4.0.3
+pkgrel=0
+pkgdesc="LibreOffice - Meta package for the full office suite"
+url="http://www.libreoffice.org/"
+arch="all"
+license="MPL2"
+depends_dev="cups-dev libjpeg-turbo-dev boost-dev clucene-dev libe-book-dev icu-dev
+ libetonyek-dev libwpd-dev libwpg-dev libmspub-dev libmwaw-dev libpagemaker-dev
+ libvisio-dev libcmis-dev lcms2-dev cppunit-dev freetype-dev libabw-dev libwps-dev
+ libxslt-dev postgresql-dev mdds-dev glm-dev glu-dev glew-dev vigra-dev
+ unixodbc-dev openldap-dev openssl-dev nss-dev npapi-sdk hunspell-dev
+ libxrender-dev libxrandr-dev neon-dev apr-dev redland-dev libexttextcat-dev
+ gconf-dev bluez-dev gstreamer1-dev gst-plugins-base1-dev gtk+2.0-dev
+ poppler-dev cairo-dev hyphen-dev mythes-dev python3-dev harfbuzz-dev
+ libfreehand-dev libodfgen-dev libcdr-dev"
+makedepends="$depends_dev autoconf automake tar coreutils ucpp gperf bison flex
+ zip perl perl-archive-zip sed"
+# GNU sed is needed for in i18npool/CustomTarget_localedata.mk
+install=""
+subpackages="$pkgname-base $pkgname-calc $pkgname-common $pkgname-draw
+ $pkgname-gnome $pkgname-impress $pkgname-lang-en_us $pkgname-math
+ $pkgname-connector-postgres $pkgname-writer"
+depends="$subpackages"
+_addsrcurl="http://dev-www.libreoffice.org/src"
+source="http://download.documentfoundation.org/libreoffice/src/4.4.0/libreoffice-$pkgver.tar.xz
+ $_addsrcurl/1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
+ linux-musl.patch
+ fix-execinfo.patch
+ fix-includes.patch
+ "
+
+_builddir="$srcdir"/libreoffice-$pkgver
+unpack() {
+ if [ -z "$force" ]; then
+ verify || return 1
+ initdcheck || return 1
+ fi
+ mkdir -p "$srcdir"
+ msg "Unpacking sources..."
+
+ local u
+ for u in $source; do
+ local s="$SRCDEST/$(filename_from_uri $u)"
+ case $s in
+ */libreoffice-*.tar.xz)
+ msg "Unpacking $s..."
+ unxz -c "$s" | tar -C "$srcdir" -x || return 1;;
+ esac
+ done
+}
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ # https://bugs.documentfoundation.org/show_bug.cgi?id=78174
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=64812
+ # gcc 4.9.x -fvisibility-inlines-hidden is broken, force disable it for now
+ sed -e 's/@HAVE_GCC_VISIBILITY_BROKEN@/TRUE/g' -i config_host.mk.in
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-vendor="Alpine Linux" \
+ --disable-online-update \
+ --disable-fetch-external \
+ --disable-dependency-tracking \
+ --disable-crashdump \
+ --enable-release-build \
+ --enable-split-app-modules \
+ --enable-verbose \
+ --enable-python=system \
+ --with-alloc=system \
+ --with-tls=openssl \
+ --with-system-libs \
+ --with-system-dicts \
+ --with-system-ucpp \
+ --with-external-dict-dir=/usr/share/hunspell \
+ --with-external-hyph-dir=/usr/share/hyphen \
+ --with-external-tar="$srcdir" \
+ --without-java \
+ --without-fonts \
+ --without-system-sane \
+ --without-myspell-dicts \
+ --disable-firebird-sdbc \
+ --disable-orcus \
+ --disable-graphite \
+ --disable-coinmp \
+ --disable-lpsolve \
+ --disable-gltf \
+ --disable-liblangtag \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir"/../all distro-pack-install || return 1
+}
+
+_split() {
+ depends=""
+
+ local i
+ for i in $(grep -v ^%dir $_builddir/file-lists/${1}_list.txt | sort -u); do
+ dirname="$(dirname $i)"
+ [ -d "$subpkgdir/$dirname" ] || install -dm755 "$subpkgdir/$dirname"
+ mv "$pkgdir"/../all/"$i" "$subpkgdir"/"$i"
+ done
+}
+
+base() {
+ pkgdesc="LibreOffice - Database frontend"
+ _split base
+}
+
+calc() {
+ pkgdesc="LibreOffice - Spreadsheet"
+ _split calc
+}
+
+common() {
+ pkgdesc="LibreOffice - Common files"
+ _split common
+}
+
+draw() {
+ pkgdesc="LibreOffice - Drawing application"
+ _split draw
+}
+
+gnome() {
+ pkgdesc="LibreOffice - GNOME integration"
+ _split gnome
+}
+
+impress() {
+ pkgdesc="LibreOffice - Presentation application"
+ _split impress
+}
+
+en_us() {
+ pkgdesc="LibreOffice - English (US) language pack"
+ _split lang_en_US
+}
+
+math() {
+ pkgdesc="LibreOffice - Equation editor"
+ _split math
+}
+
+postgres() {
+ pkgdesc="LibreOffice - Connector for PostgreSQL database"
+ _split postgresql
+}
+
+writer() {
+ pkgdesc="LibreOffice - Word Processor"
+ _split writer
+}
+
+md5sums="34cf1a7fbac5b496c141c32c8464a73a libreoffice-4.4.0.3.tar.xz
+1f24ab1d39f4a51faf22244c94a6203f 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
+69bef53b6dc9d39d59d1514d02dbbcf7 linux-musl.patch
+1cff63a520d1b037edddf1b4de4799dc fix-execinfo.patch
+2410b3fef56a2163a0d3142330ecbcdc fix-includes.patch"
+sha256sums="d168f3d27e840a861def7739515b4093635c422275b11b25bddd783519300cf7 libreoffice-4.4.0.3.tar.xz
+390a5085651828b8fe12aa978b200f59b9155eedbb91a4be89bf7cf39eefdd4a 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
+5cf5a446e5769f6a2df01c5c10702514fe9178334d1e53d3c7df843ca72c6fa2 linux-musl.patch
+7171dfa651a7ee81b4e13a9fd9131428d9a65af138cac4cb428ae6c3e4bcb1f3 fix-execinfo.patch
+2044d4c997472a46e95c68fa8bec19c1424e9074fad05df9f1c0d220dec00281 fix-includes.patch"
+sha512sums="0792b9441a2030fdd1b3f4afc660993d63a069575e6426e3cf367fd8a57c684bf0cfcedc82e8bdc473b057cd6f5b471a773e98b148333f4e5885e5b8a1f9bfb8 libreoffice-4.4.0.3.tar.xz
+5664203e6426880041cdb227e91f79f00d2ca7ae28c6997f61b72cc599aac55838d082d2b2b551bd7a228424c350ddea5d41599b8ca58d444a2cd46c9206ea91 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
+5fb4d5bf5cab21a0c95a9e51a4a138b427a08677c34bc14287c3eb74926b606345d5185c76bbe8957043d79dc33d46cf4aaa5182642c7fb9136dc48ed9e7fabb linux-musl.patch
+567123f990c4a47c2e4cebf99f3486150740015e647ca2b2521e606f3350fc55ceda6c7ac031302da34e8fc90747d66619334fcfda4e7b8998456fe3619ab860 fix-execinfo.patch
+15defc8362fb0e53db32b75d9c4ece73e1ee8bd1cc05b4dd8f072f808e6943b385a5415513b237d3daa130dedce3c6ac6370e05ec0b4a25065ce27aadd269e92 fix-includes.patch"
diff --git a/testing/libreoffice/fix-execinfo.patch b/testing/libreoffice/fix-execinfo.patch
new file mode 100644
index 00000000000..01fca6fb2e6
--- /dev/null
+++ b/testing/libreoffice/fix-execinfo.patch
@@ -0,0 +1,24 @@
+diff -ru sal.orig/osl/unx/backtrace.h sal/osl/unx/backtrace.h
+--- a/sal/osl/unx/backtrace.h 2015-01-22 22:05:28.000000000 -0200
++++ b/sal/osl/unx/backtrace.h 2015-02-02 17:06:27.765494731 -0200
+@@ -47,7 +47,7 @@
+
+ #endif /* defined SOLARIS || FREEBSD || NETBSD || OPENBSD */
+
+-#if defined (LINUX)
++#if defined (LINUX) && defined (__GLIBC__)
+ #include <execinfo.h>
+ #endif
+
+diff -ru sal.orig/osl/unx/signal.cxx sal/osl/unx/signal.cxx
+--- a/sal/osl/unx/signal.cxx 2015-01-22 22:05:28.000000000 -0200
++++ b/sal/osl/unx/signal.cxx 2015-02-02 17:06:53.495496086 -0200
+@@ -36,7 +36,7 @@
+
+ #endif /* MACOSX */
+
+-#ifdef LINUX
++#if defined (LINUX) && defined (__GLIBC__)
+ #include <execinfo.h>
+ #include <link.h>
+ #define INCLUDE_BACKTRACE
diff --git a/testing/libreoffice/fix-includes.patch b/testing/libreoffice/fix-includes.patch
new file mode 100644
index 00000000000..b1f1b44101d
--- /dev/null
+++ b/testing/libreoffice/fix-includes.patch
@@ -0,0 +1,31 @@
+--- libreoffice-4.4.0.3/vcl/inc/headless/svpinst.hxx 2015-02-02 20:38:46.879497689 -0200
++++ libreoffice-4.4.0.3/vcl/inc/headless/svpinst.hxx 2015-02-02 20:38:55.482831474 -0200
+@@ -32,6 +32,7 @@
+ #include <list>
+
+ #include <time.h>
++#include <sys/time.h>
+
+ #define VIRTUAL_DESKTOP_WIDTH 1024
+ #define VIRTUAL_DESKTOP_HEIGHT 768
+--- libreoffice-4.4.0.3/vcl/unx/generic/gdi/cairotextrender.cxx 2015-02-02 21:19:22.822959064 -0200
++++ libreoffice-4.4.0.3/vcl/unx/generic/gdi/cairotextrender.cxx 2015-02-02 21:19:48.312960404 -0200
+@@ -18,6 +18,7 @@
+ */
+
+ #include "cairotextrender.hxx"
++#include "generic/glyphcache.hxx"
+
+ #include <basegfx/polygon/b2dpolypolygon.hxx>
+ #include <vcl/settings.hxx>
+--- libreoffice-4.4.0.3/sd/source/ui/remotecontrol/BluetoothServer.cxx 2015-02-03 08:42:36.590056362 -0200
++++ libreoffice-4.4.0.3/sd/source/ui/remotecontrol/BluetoothServer.cxx 2015-02-03 08:42:46.030056456 -0200
+@@ -22,7 +22,7 @@
+ #include <dbus/dbus.h>
+ #include <errno.h>
+ #include <fcntl.h>
+- #include <sys/unistd.h>
++ #include <unistd.h>
+ #include <sys/socket.h>
+ #include <bluetooth/bluetooth.h>
+ #include <bluetooth/rfcomm.h>
diff --git a/testing/libreoffice/linux-musl.patch b/testing/libreoffice/linux-musl.patch
new file mode 100644
index 00000000000..5c8ab52976c
--- /dev/null
+++ b/testing/libreoffice/linux-musl.patch
@@ -0,0 +1,68 @@
+--- libreoffice-4.4.0.3/configure.ac.orig 2015-01-22 22:05:28.000000000 -0200
++++ libreoffice-4.4.0.3/configure.ac 2015-02-02 20:11:20.639411153 -0200
+@@ -569,7 +569,7 @@
+ fi
+ ;;
+
+-linux-gnu*|k*bsd*-gnu*)
++linux-gnu*|linux-musl*|k*bsd*-gnu*)
+ test_gtk=yes
+ build_gstreamer_1_0=yes
+ build_gstreamer_0_10=yes
+@@ -4058,7 +4058,7 @@
+ esac
+ ;;
+
+-linux-gnu*)
++linux-gnu*|linux-musl*)
+ COM=GCC
+ GUIBASE=unx
+ OS=LINUX
+@@ -6967,7 +6967,7 @@
+ test -d "$JAVA_HOME/include/native_thread" && JAVAINC="$JAVAINC -I$JAVA_HOME/include/native_thread"
+ ;;
+
+- linux-gnu*)
++ linux-gnu*|linux-musl*)
+ JAVAINC="-I$JAVA_HOME/include"
+ JAVAINC="$JAVAINC -I$JAVA_HOME/include/linux"
+ test -d "$JAVA_HOME/include/native_thread" && JAVAINC="$JAVAINC -I$JAVA_HOME/include/native_thread"
+@@ -9429,21 +9429,6 @@
+ fi
+ AC_SUBST(SYSTEM_LIBEXTTEXTCAT_DATA)
+
+-dnl ***************************************
+-dnl testing libc version for Linux...
+-dnl ***************************************
+-if test "$_os" = "Linux"; then
+- AC_MSG_CHECKING([whether libc is >= 2.1.1])
+- exec 6>/dev/null # no output
+- AC_CHECK_LIB(c, gnu_get_libc_version, HAVE_LIBC=yes; export HAVE_LIBC)
+- exec 6>&1 # output on again
+- if test "$HAVE_LIBC"; then
+- AC_MSG_RESULT([yes])
+- else
+- AC_MSG_ERROR([no, upgrade libc])
+- fi
+-fi
+-
+ dnl =========================================
+ dnl Check for the Windows SDK.
+ dnl =========================================
+@@ -12741,7 +12726,7 @@
+
+ case "$host_os" in
+
+- aix*|dragonfly*|freebsd*|linux-gnu*|*netbsd*|openbsd*)
++ aix*|dragonfly*|freebsd*|linux-gnu*|linux-musl*|*netbsd*|openbsd*)
+ if test "$ENABLE_JAVA" != "" -a "$JDK"!="gcj"; then
+ pathmunge "$JAVA_HOME/bin" "after"
+ fi
+@@ -12789,7 +12774,6 @@
+ esac
+
+ pathmunge "$SRC_ROOT/solenv/bin" "before"
+- pathmunge "." "before"
+ fi
+
+ AC_SUBST(LO_PATH)