aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libretro-daphne/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libretro-daphne/APKBUILD')
-rw-r--r--testing/libretro-daphne/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/libretro-daphne/APKBUILD b/testing/libretro-daphne/APKBUILD
new file mode 100644
index 00000000000..1171f9d3765
--- /dev/null
+++ b/testing/libretro-daphne/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-daphne
+pkgver=0_git20210108
+pkgrel=1
+_commit="0a7e6f0fda1348144369ce0a889876df60263e8f"
+pkgdesc="daphne core for libretro"
+url="https://github.com/libretro/daphne"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="libogg-dev libvorbis-dev zlib-dev"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/daphne/archive/$_commit.tar.gz
+ patch-unbundle.patch
+ "
+builddir="$srcdir/daphne-$_commit"
+options="!check" # No tests
+
+build() {
+ rm -rf deps
+ make
+}
+
+package() {
+ install -Dm644 daphne_libretro.so "$pkgdir"/usr/lib/libretro/daphne_libretro.so
+}
+
+sha512sums="8af1018ad596887a4a8b64683e89d76010a92677dca5d0d3062f5697b97f5135e25517fae7ed9037c6da947c5162353d31569c629cba154401b76c7ba46d3d6b libretro-daphne-0a7e6f0fda1348144369ce0a889876df60263e8f.tar.gz
+308588bdafbc470390e53d84c6e5b11a4760e194879add00214960f2625be243ed199205ecbda881ae0616b3d163a216602a776cb3d304da3ec81a8ec1ae298e patch-unbundle.patch"