aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libretro-neocd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libretro-neocd/APKBUILD')
-rw-r--r--testing/libretro-neocd/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/libretro-neocd/APKBUILD b/testing/libretro-neocd/APKBUILD
new file mode 100644
index 00000000000..74d115f0bec
--- /dev/null
+++ b/testing/libretro-neocd/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-neocd
+pkgver=0_git20220325
+pkgrel=0
+_commit="327aeceecdf71c8a0c0af3d6dc53686c94fe44ad"
+pkgdesc="libretro core for neocd"
+url="https://github.com/libretro/neocd_libretro"
+arch="all"
+license="LGPL-3.0-only"
+makedepends="minizip-dev libogg-dev libvorbis-dev zlib-dev"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/neocd_libretro/archive/$_commit.tar.gz
+ patch-unbundle.patch"
+builddir="$srcdir/neocd_libretro-$_commit"
+options="!check" # No tests
+
+build() {
+ rm -rf deps/libogg deps/libvorbis deps/libchdr/deps/zlib*
+ make -j1
+}
+
+package() {
+ install -Dm644 neocd_libretro.so "$pkgdir"/usr/lib/libretro/neocd_libretro.so
+}
+
+sha512sums="
+12c4a848aac6e5ea91deeec64e68e4f9c54181047c53322f0fc912100a61318e99b2939d33d0b94ef8c4bad5dd537cadf875a1d8cc6c5e069b7b3cba1c49d573 libretro-neocd-327aeceecdf71c8a0c0af3d6dc53686c94fe44ad.tar.gz
+bc689c7c686f917dbaff889ddef761a89d2f552ca0905f0c9c554e3d4c8117fc4a972a3dc1322699f0ff558db7a71b6206a383a34ca3739d8ca82a5c11d81da8 patch-unbundle.patch
+"