aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libthai/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libthai/APKBUILD')
-rw-r--r--testing/libthai/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/libthai/APKBUILD b/testing/libthai/APKBUILD
new file mode 100644
index 00000000000..897be0ae911
--- /dev/null
+++ b/testing/libthai/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Alex Yam <alex@alexyam.com>
+# Maintainer: Alex Yam <alex@alexyam.com>
+pkgname=libthai
+pkgver=0.1.29
+pkgrel=0
+pkgdesc="Thai language library"
+url="https://github.com/tlwg/libthai"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="doxygen libdatrie libdatrie-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/tlwg/libthai/releases/download/v$pkgver/libthai-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+0ba1261581a1705a2a2546a3071acb3c63892dbf111f0dad415667165a6b9542a5e4549061c67b11ec53de7c9e70fceb3c04d794fd12a22d991a539dbacebda1 libthai-0.1.29.tar.xz
+"