aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libtommath/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libtommath/APKBUILD')
-rw-r--r--testing/libtommath/APKBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/testing/libtommath/APKBUILD b/testing/libtommath/APKBUILD
index dd13f8b1181..2d8f438d470 100644
--- a/testing/libtommath/APKBUILD
+++ b/testing/libtommath/APKBUILD
@@ -1,39 +1,36 @@
# Contributor: Alex Yam <alex@alexyam.com>
# Maintainer: Alex Yam <alex@alexyam.com>
pkgname=libtommath
-pkgver=0_git20210103
-_commit=eda0bd6ae5705ab90b866dfb52c5f15c23687f81
+pkgver=1.2.1
pkgrel=0
pkgdesc="number theoretic multiple-precision integer library"
url="https://www.libtom.net/LibTomMath/"
-# arch: all except x86 and x86_64 failed 2 tests:
-# test_mp_sqrtmod_prime, line 726: DO(mp_sqrtmod_prime(&b, &a, &c)) failed: Value out of range
-# test_mp_kronecker, line 345: EXPECT(i == kronecker[cnt].c[m + 10]) failed
-arch="all !armhf !armv7 !aarch64 !ppc64le !s390x !mips !mips64"
+arch="all"
license="Unlicense"
makedepends="libtool"
-checkdepends="coreutils" # Using BusyBox's "timeout" resulted in - unrecognized option: foreground
subpackages="$pkgname-dev"
-source="$pkgname-$_commit.tar.gz::https://github.com/libtom/libtommath/archive/$_commit.tar.gz"
-builddir=$srcdir/$pkgname-$_commit
+source="$pkgname-$pkgver.tar.xz::https://github.com/libtom/libtommath/releases/download/v$pkgver/ltm-$pkgver.tar.xz"
+
+# secfixes:
+# 1.2.1-r0:
+# - CVE-2023-36328
build() {
make -f makefile.shared
}
check() {
- # testme.sh runs its own CC and make
- # resulting in .lo files in $builddir that break package() with error:
- # "libtool: error: 'mp_2expt.lo' is not a valid libtool object"
- # clone $builddir to testdir for running testme.sh
- cp -rp $builddir $builddir/../testdir
- cd $builddir/../testdir
- ./testme.sh
- cat test_gcc.log
+ # make test creates a stand-alone test binary that executes several test routines.
+ # clone $builddir to testdir for running tests
+ cp -rp $builddir $srcdir/testdir
+ cd $srcdir/testdir
+ make test
}
package() {
make DESTDIR="$pkgdir" LIBPATH=/usr/lib INCPATH=/usr/include -f makefile.shared install
}
-sha512sums="f5307463d7b9854c9867a58ca07941eba6108a04e29cb750ef156c7950798bf5cbab199c6d1f549b8d4fd6e8ba95b4581b10883ef7b4a3b00d57819600b521e4 libtommath-eda0bd6ae5705ab90b866dfb52c5f15c23687f81.tar.gz"
+sha512sums="
+50c9459357aa7f5076af93de6701c617da0dbbf2230a2f4468062704a6cd6e9d3c2fbb27016f68a7e1d6b35d6ddb2088630b24ea6acc20ed8c19594913d36e95 libtommath-1.2.1.tar.xz
+"