aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libuecc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libuecc/APKBUILD')
-rw-r--r--testing/libuecc/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/testing/libuecc/APKBUILD b/testing/libuecc/APKBUILD
index 147dd1efe8e..8add61d168e 100644
--- a/testing/libuecc/APKBUILD
+++ b/testing/libuecc/APKBUILD
@@ -1,27 +1,28 @@
# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
-# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=libuecc
pkgver=7
-pkgrel=1
+pkgrel=3
pkgdesc="Very small Elliptic Curve Cryptography library"
-options="!check" # No testsuite
url="https://git.universe-factory.net/libuecc"
arch="all"
license="BSD-2-Clause"
makedepends="cmake"
+options="!check" # No testsuite
subpackages="$pkgname-dev"
-source="https://git.universe-factory.net/${pkgname}/snapshot/${pkgname}-${pkgver}.tar"
+source="https://git.universe-factory.net/libuecc/snapshot/libuecc-$pkgver.tar"
build() {
- mkdir build
- cd build
- cmake -D CMAKE_INSTALL_PREFIX=/usr ..
- make
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ .
+ make -C build
}
package() {
- cd "$builddir/build"
- make install DESTDIR="${pkgdir}"
+ make -C build DESTDIR="$pkgdir" install
rm -f "$pkgdir"/usr/lib/*.a
}