aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libui/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libui/APKBUILD')
-rw-r--r--testing/libui/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/libui/APKBUILD b/testing/libui/APKBUILD
new file mode 100644
index 00000000000..508b500503d
--- /dev/null
+++ b/testing/libui/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer:
+pkgname=libui
+pkgver=4.1_alpha20211213
+_commit=fea45b2d5b75839be0af9acc842a147c5cba9295
+pkgrel=0
+pkgdesc="Simple and portable GUI library for C"
+url="https://github.com/andlabs/libui"
+arch="all"
+license="MIT"
+options="!check" # no test suite
+makedepends="
+ meson
+ gtk+3.0-dev
+ "
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/andlabs/libui/archive/$_commit.tar.gz"
+builddir="$srcdir/$pkgname-$_commit"
+
+build() {
+ pwd
+ echo $builddir
+ abuild-meson . output
+ meson compile -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+59f31e0b0afff0f41592f5edaa495b89275e1bc7329312145dcea2896aa2898658b60c187be8f805b4cf1c23ce1ae4171c637f115d716998569d5c53e103217b libui-4.1_alpha20211213.tar.gz
+"