aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libvolk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libvolk/APKBUILD')
-rw-r--r--testing/libvolk/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/testing/libvolk/APKBUILD b/testing/libvolk/APKBUILD
deleted file mode 100644
index 764457a1827..00000000000
--- a/testing/libvolk/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-pkgname=libvolk
-pkgver=2.3.0
-pkgrel=0
-pkgdesc="Vector-Optimized Library of Kernels"
-url="https://www.libvolk.org/"
-# libvolk provides hand-written SIMD code. Hence, support needs to be manually
-# added to new platforms. Currently only supported are:
-arch="armv7 aarch64 x86_64"
-license="GPL-3.0-or-later"
-makedepends="cmake py3-mako boost-dev orc-dev"
-subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/gnuradio/volk/archive/v$pkgver.tar.gz
- failing_tests.patch
- "
-builddir="$srcdir/volk-$pkgver"
-
-build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-
-check() {
- cmake --build build --target test
-}
-
-sha512sums="9e3b405b7be46b4f5ff61a4d42fa9013fc55169bc18c9cf9253e446fe23fd12dc0356adb9aa176e33dfa4cc478e4b9226bee906a2d89ef83bac3b28f52816382 libvolk-2.3.0.tar.gz
-0162991175e8b90df990bcc65ac4fadb72036e55b77eef00775af5c14c84938e4341c6a846ea6a678fa54548ab4bf1164aa00cb0044613195632165a91e5f8fb failing_tests.patch"