aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libxml++/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libxml++/APKBUILD')
-rw-r--r--testing/libxml++/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/testing/libxml++/APKBUILD b/testing/libxml++/APKBUILD
index 0c9be67e674..0054c103359 100644
--- a/testing/libxml++/APKBUILD
+++ b/testing/libxml++/APKBUILD
@@ -1,32 +1,40 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libxml++
-pkgver=3.2.2
-pkgrel=0
+pkgver=5.0.3
+pkgrel=1
pkgdesc="C++ wrapper for the libxml XML parser library"
-url="http://libxmlplusplus.sourceforge.net/"
+url="https://libxmlplusplus.sourceforge.net/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="meson libxml2-dev glibmm-dev python3 perl doxygen graphviz"
-subpackages="$pkgname-dev $pkgname-doc"
+makedepends="
+ libxml2-dev
+ meson
+ mm-common
+ python3
+ "
+subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/libxml++/${pkgver%.[0-9]*}/libxml++-$pkgver.tar.xz"
+options="!check" # fail against new libxml
build() {
abuild-meson \
+ -Db_lto=true \
-Dbuild-tests=true \
-Dbuild-examples=false \
- -Dbuild-documentation=true \
+ -Dbuild-documentation=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
- ln -s libxml++-3.0.pc "$pkgdir"/usr/lib/pkgconfig/libxml++.pc
}
-sha512sums="c000d438aae487b92de2a1c60277d5e3ad3bf93824fc8fa99684778ea2334a45bf621f8d253190bdadedc591772d9beee53a98ebc3e20015d2ca68e097c0a253 libxml++-3.2.2.tar.xz"
+sha512sums="
+418723a96f018fb8e332847d0ab601eda38c99d6be48c83b6cda6f07789e5ecac76bb417540e29d0abace2828a74eb1e08695ff2fc92ebf3e7458364547ef675 libxml++-5.0.3.tar.xz
+"