aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libzim/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libzim/APKBUILD')
-rw-r--r--testing/libzim/APKBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/testing/libzim/APKBUILD b/testing/libzim/APKBUILD
deleted file mode 100644
index 0890fd2fe22..00000000000
--- a/testing/libzim/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Oleg Titov <oleg.titov@gmail.com>
-# Maintainer: Oleg Titov <oleg.titov@gmail.com>
-pkgname=libzim
-pkgver=7.0.0
-pkgrel=0
-pkgdesc="Reference implementation of the ZIM file format"
-url="https://openzim.org/"
-arch="all !mips !mips64" # tests crash
-license="GPL-2.0-or-later"
-options="!check" # requieres external test data files
-makedepends="
- icu-dev
- libexecinfo-dev
- meson
- xapian-core-dev
- xz-dev
- zlib-dev
- zstd-dev
- "
-checkdepends="
- cython
- gtest-dev
- python3-dev
- "
-subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/openzim/libzim/archive/$pkgver.tar.gz"
-
-build() {
- LDFLAGS="$LDFLAGS -lexecinfo"
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
-}
-
-check() {
- meson test --no-rebuild -v -C output
-}
-
-package() {
- DESTDIR="$pkgdir" meson install --no-rebuild -C output
-
- install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md
-}
-
-sha512sums="
-fc2932e05140c6a89a716bc6cbf285af326d9a3367aa60cd6fc95cbc5e46aacf7a5b90c673728bf01d82b45a5f6011f2fbc9c2d10623f31491c847842593c233 libzim-7.0.0.tar.gz
-"