aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lighthouse/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lighthouse/APKBUILD')
-rw-r--r--testing/lighthouse/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/testing/lighthouse/APKBUILD b/testing/lighthouse/APKBUILD
deleted file mode 100644
index 2c2c56106e0..00000000000
--- a/testing/lighthouse/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: Oleg Titov <oleg.titov@gmail.com>
-# Maintainer: Oleg Titov <oleg.titov@gmail.com>
-pkgname=lighthouse
-pkgver=1.4.0
-pkgrel=0
-pkgdesc="Ethereum 2.0 Client"
-url="https://lighthouse.sigmaprime.io/"
-arch="x86_64 !aarch64" # limited by upstream
-license="Apache-2.0"
-makedepends="cargo cmake openssl-dev protoc"
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sigp/lighthouse/archive/v$pkgver/lighthouse-$pkgver.tar.gz"
-
-export OPENSSL_NO_VENDOR=true
-export RUSTFLAGS="$RUSTFLAGS -L /usr/lib/"
-
-build() {
- cargo build --release --locked
-}
-
-check() {
- cargo test --release --locked \
- --workspace \
- --exclude ef_tests \
- --exclude eth1 \
- --exclude genesis
-}
-
-package() {
- install -D -m755 "target/release/lighthouse" "$pkgdir/usr/bin/lighthouse"
-
- install -Dm 644 -t "$pkgdir/usr/share/doc/lighthouse" README.md
-}
-
-sha512sums="
-94687eb5c68c9e1fbb331b1d0f93badb91ebfc856cbf49d317d8a786a79b632f6e0f539ad0409fbe55ae1e42cda567e7fdc3e2365b59011f4957e0d2f8a717ef lighthouse-1.4.0.tar.gz
-"