aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lighthouse/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lighthouse/APKBUILD')
-rw-r--r--testing/lighthouse/APKBUILD38
1 files changed, 0 insertions, 38 deletions
diff --git a/testing/lighthouse/APKBUILD b/testing/lighthouse/APKBUILD
deleted file mode 100644
index 640bc5696b0..00000000000
--- a/testing/lighthouse/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: Oleg Titov <oleg.titov@gmail.com>
-# Maintainer: Oleg Titov <oleg.titov@gmail.com>
-pkgname=lighthouse
-pkgver=2.0.1
-pkgrel=0
-pkgdesc="Ethereum 2.0 Client"
-url="https://lighthouse.sigmaprime.io/"
-arch="x86_64 aarch64" # limited by upstream
-license="Apache-2.0"
-makedepends="cargo cmake openssl-dev protoc"
-options="!check" # disable check as it takes too long
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sigp/lighthouse/archive/v$pkgver/lighthouse-$pkgver.tar.gz"
-
-export OPENSSL_NO_VENDOR=true
-export RUSTFLAGS="$RUSTFLAGS -L /usr/lib/"
-
-build() {
- cargo build --release --locked
-}
-
-check() {
- cargo test --release --locked \
- --workspace \
- --exclude ef_tests \
- --exclude eth1 \
- --exclude genesis
-}
-
-package() {
- install -D -m755 "target/release/lighthouse" "$pkgdir/usr/bin/lighthouse"
-
- install -Dm 644 -t "$pkgdir/usr/share/doc/lighthouse" README.md
-}
-
-sha512sums="
-c4edabae566fec8cc1c88b7efa73683cf963d15bf1f44a4da35dc9361ad82d684c2844ff02c4a2fdbab7a790e16a9ccd3822c696412be3f769e986b49ff1e0f0 lighthouse-2.0.1.tar.gz
-"