aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lighthouse/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lighthouse/APKBUILD')
-rw-r--r--testing/lighthouse/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/lighthouse/APKBUILD b/testing/lighthouse/APKBUILD
new file mode 100644
index 00000000000..a9a4075f6f6
--- /dev/null
+++ b/testing/lighthouse/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=lighthouse
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="Ethereum 2.0 Client"
+url="https://lighthouse.sigmaprime.io/"
+arch="x86_64 aarch64" # limited by upstream
+license="Apache-2.0"
+makedepends="cargo cmake openssl-dev protoc"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sigp/lighthouse/archive/v$pkgver/lighthouse-$pkgver.tar.gz"
+
+export OPENSSL_NO_VENDOR=true
+export RUSTFLAGS="$RUSTFLAGS -L /usr/lib/"
+
+build() {
+ cargo build --release --locked
+}
+
+check() {
+ cargo test --release --locked \
+ --workspace \
+ --exclude ef_tests \
+ --exclude eth1 \
+ --exclude genesis
+}
+
+package() {
+ install -D -m755 "target/release/lighthouse" "$pkgdir/usr/bin/lighthouse"
+
+ install -Dm 644 -t "$pkgdir/usr/share/doc/lighthouse" README.md
+}
+
+sha512sums="56c5887c3932d376b82084d1cad810bbfba664cbd8899907021c9ecf6243d5c45c2a79913998fe005abe91e700d349616939958bcb17b3eed9c246ad48712d1e lighthouse-1.3.0.tar.gz"