aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lite-xl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lite-xl/APKBUILD')
-rw-r--r--testing/lite-xl/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/lite-xl/APKBUILD b/testing/lite-xl/APKBUILD
new file mode 100644
index 00000000000..2c527aa9df8
--- /dev/null
+++ b/testing/lite-xl/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jakub Panek <me@panekj.dev>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=lite-xl
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Lightweight text editor written in Lua"
+url="https://lite-xl.github.io"
+arch="all"
+license="MIT"
+makedepends="
+ cmake
+ freetype-dev
+ lua5.4-dev
+ meson
+ pcre2-dev
+ reproc-dev
+ sdl2-dev
+ "
+subpackages="$pkgname-doc"
+source="https://github.com/lite-xl/lite-xl/archive/v$pkgver/lite-xl-$pkgver.tar.gz"
+options="!check" # no tests available
+
+build() {
+ abuild-meson -Darch_tuple="$CARCH-linux" . output
+ meson compile -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+224bf8e2629f2dcd9bc5c8468a0f3f8fd6453db910241e79c8d3ba6902202a31df8381f0dd9c5fb797ad98df7bc122ea288accb58353fe310ed770d0874268e5 lite-xl-2.1.1.tar.gz
+"