aboutsummaryrefslogtreecommitdiffstats
path: root/testing/log4cxx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/log4cxx/APKBUILD')
-rw-r--r--testing/log4cxx/APKBUILD51
1 files changed, 24 insertions, 27 deletions
diff --git a/testing/log4cxx/APKBUILD b/testing/log4cxx/APKBUILD
index 7ad4bdd3f5f..31860573a6e 100644
--- a/testing/log4cxx/APKBUILD
+++ b/testing/log4cxx/APKBUILD
@@ -1,48 +1,45 @@
# Contributor: Russ Webber <russ@rw.id.au>
# Maintainer: Russ Webber <russ@rw.id.au>
pkgname=log4cxx
-pkgver=0.10.0
+pkgver=1.1.0
pkgrel=1
pkgdesc="C++ port of the Log4j logging framework"
url="http://logging.apache.org/log4cxx"
license="Apache-2.0"
-options="!check" # testsuite in 0.10.0 does not work on alpine
-subpackages="$pkgname-static $pkgname-dev"
+options="!check" # testsuite in 1.1.0 does not work on alpine
+subpackages="$pkgname-dev"
arch="all"
-depends_dev="$pkgname-static"
-makedepends="autoconf automake libtool zip libxml2-dev apr-util-dev"
-source="https://archive.apache.org/dist/logging/log4cxx/$pkgver/apache-log4cxx-$pkgver.tar.gz
- log4cxx-0.10.0-missing_includes.patch
- log4cxx-0.10.0-narrowing-fixes-from-upstream.patch
- "
+makedepends="cmake zip libxml2-dev apr-util-dev samurai"
+source="https://archive.apache.org/dist/logging/log4cxx/$pkgver/apache-log4cxx-$pkgver.tar.gz"
builddir="$srcdir/apache-$pkgname-$pkgver"
-prepare() {
- update_config_guess
- update_config_sub
- default_prepare
-}
+# secfixes:
+# 1.1.0-r0:
+# - CVE-2023-31038
build() {
- # if configure is autogenerated make install seems to fail #./autogen.sh
- # does not configure if specifying --build=$CBUILD \ --host=$CHOST \
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
- make
+ cmake -B build -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ $CMAKE_CROSSOPTS
+ cmake --build build
}
check() {
- make check
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest --test-dir build -E sizebasedrollingtest
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="1c34d80983db5648bc4582ddcf6b4fdefdc6594c2769f95235f5441cd6d03cf279cc8f365e9a687085b113f79ebac9d7d33a54b6aa3b3b808c0e1a56a15ffa37 apache-log4cxx-0.10.0.tar.gz
-14fa0b19516171cbbe2c6220816819fc52cf8f3b3ded5d71966e2f4a71bda9ce1ed8fe7e57745a835e6ac5558631916ed9824d09ec7469d84c7bf99fb4946304 log4cxx-0.10.0-missing_includes.patch
-15b692b37961adbc808e4c10d2719483502f3ac060ee5be248832d4e2a2f76f7d9e120ea9a6bf908230cf230a893964040e54415cca35a12e576d0a5ab1f4176 log4cxx-0.10.0-narrowing-fixes-from-upstream.patch"
+sha512sums="
+66a66eab933a6afd0779e3f73f65afa4fb82481208b591fd7c7c86ded805f50abcd9cdf954bdb49e1e7f5198e6c1c4fff8a7e180ff5fff9491f1946e9ba6fe2b apache-log4cxx-1.1.0.tar.gz
+"