aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lolcat
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lolcat')
-rw-r--r--testing/lolcat/APKBUILD13
-rw-r--r--testing/lolcat/makefile.patch17
2 files changed, 26 insertions, 4 deletions
diff --git a/testing/lolcat/APKBUILD b/testing/lolcat/APKBUILD
index 053fd336443..69618c03f53 100644
--- a/testing/lolcat/APKBUILD
+++ b/testing/lolcat/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Daniel Isaksen <d@duniel.no>
# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
pkgname=lolcat
-pkgver=1.2
-pkgrel=1
+pkgver=1.4
+pkgrel=0
pkgdesc="High-performance implementation of lolcat"
url="https://github.com/jaseg/lolcat/"
arch="all"
license="WTFPL"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jaseg/lolcat/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jaseg/lolcat/archive/v$pkgver.tar.gz
+ makefile.patch
+ "
options="!check" # No upstream testsuite
build() {
@@ -19,4 +21,7 @@ package() {
make DESTDIR="$pkgdir/usr/bin" install
}
-sha512sums="e8db711283267a38573eee584c01c64db4d20ea057f7b7db88c93c58189e0340eadd13129723e326618995e2a3dd80e1ff24aacb2b7e3d10c077c0f5f54a1fd3 lolcat-1.2.tar.gz"
+sha512sums="
+8f73121ef372383f5ff1d444f69a6255f5ff65abfbb4f103197480f957dcc440375c7c01be5c33247ce920ff39e34519702f7550b9b8ada2f18190d0ae948024 lolcat-1.4.tar.gz
+cddac8348b17f180daa8f4c53788dc86ab348f2d5c4c98e91b7b50010e6638750e6f1c2931d115090e8075055bef2c3d4e12218fc64b4a346bfdf543c058b262 makefile.patch
+"
diff --git a/testing/lolcat/makefile.patch b/testing/lolcat/makefile.patch
new file mode 100644
index 00000000000..e9d100482a9
--- /dev/null
+++ b/testing/lolcat/makefile.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile b/Makefile
+index 9ce889d..e9ca9db 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,10 +16,10 @@ xterm256lut.h: xterm256lut_gen.py
+ python $< > $@
+
+ lolcat: lolcat.c xterm256lut.h
+- $(CC) $(CFLAGS) -o $@ $< $(LIBS)
++ $(CC) $(CFLAGS) -o $@ $< $(LIBS) $(LDFLAGS)
+
+ censor: censor.c
+- $(CC) $(CFLAGS) -o $@ $< $(LIBS)
++ $(CC) $(CFLAGS) -o $@ $< $(LIBS) $(LDFLAGS)
+
+ install: lolcat censor
+ install lolcat $(DESTDIR)/lolcat