aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lshell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lshell/APKBUILD')
-rw-r--r--testing/lshell/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/lshell/APKBUILD b/testing/lshell/APKBUILD
index 4dda81644c9..0c561f4bde6 100644
--- a/testing/lshell/APKBUILD
+++ b/testing/lshell/APKBUILD
@@ -2,22 +2,26 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=lshell
pkgver=0.9.18
-pkgrel=6
+pkgrel=11
pkgdesc="Python3-based limited Shell"
url="https://github.com/ghantoos/lshell"
arch="noarch"
license="GPL-3.0-or-later"
depends="python3"
-makedepends="py3-setuptools"
-subpackages="$pkgname-doc"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-doc $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ghantoos/lshell/archive/$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
+ mv "$pkgdir"/usr/lib/python3*/site-packages/etc "$pkgdir"
}
sha512sums="546e55fd04d9913adbf6ff181d365f0aff8c94131229d4be994b29e94b925943fb32f99dc145172938535565f69405d0edad5bd2d9b7125f8770d0f0c591fece lshell-0.9.18.tar.gz"