summaryrefslogtreecommitdiffstats
path: root/testing/luaexpat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/luaexpat/APKBUILD')
-rw-r--r--testing/luaexpat/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/luaexpat/APKBUILD b/testing/luaexpat/APKBUILD
new file mode 100644
index 00000000000..e11ba107501
--- /dev/null
+++ b/testing/luaexpat/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=luaexpat
+pkgver=1.1
+pkgrel=0
+pkgdesc="LuaExpat is a SAX XML parser based on the Expat library. LuaExpat is free software and uses the same license as Lua 5.0."
+url="http://luaforge.net/projects/luaexpat/"
+license="MIT"
+depends="lua expat uclibc"
+makedepends="lua-dev expat-dev"
+install=
+source="http://luaforge.net/frs/download.php/2469/$pkgname-$pkgver.tar.gz
+newconfig"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mv ../newconfig ./config
+
+ make || return 1
+ make LUA_DIR="$pkgdir"/usr/share/lua/5.1 LUA_LIBDIR="$pkgdir"/usr/lib/lua/5.1 install
+
+}
+
+md5sums="6ecb895ccf5cff1e7f2facd438b1f8d0 luaexpat-1.1.tar.gz
+eb947b7aa99b487289b02c1ab1b8ccd3 newconfig"