aboutsummaryrefslogtreecommitdiffstats
path: root/testing/luau/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/luau/APKBUILD')
-rw-r--r--testing/luau/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/luau/APKBUILD b/testing/luau/APKBUILD
deleted file mode 100644
index f70543af10c..00000000000
--- a/testing/luau/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Rob Blanckaert <basicer@gmail.com>
-# Maintainer: Rob Blanckaert <basicer@gmail.com>
-pkgname=luau
-pkgver=0.507
-pkgrel=0
-pkgdesc="A fast, small, safe, gradually typed embeddable scripting language derived from Lua"
-url="https://github.com/roblox/luau"
-arch="all"
-license="MIT"
-makedepends="cmake"
-source="$pkgname-$pkgver.tar.gz::https://github.com/Roblox/luau/archive/refs/tags/$pkgver.tar.gz"
-
-build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- $CMAKE_CROSSOPTS .
- make
-}
-
-check() {
- $builddir/Luau.UnitTest && $builddir/Luau.Conformance
-}
-
-package() {
- install -Dm755 luau "$pkgdir"/usr/bin/luau
- install -Dm755 luau-analyze "$pkgdir"/usr/bin/luau-analyze
-}
-
-sha512sums="83fd8df8e1ccface02407bc3fc511693de24e62eedc11f7c1d0ef939ff2ce6544f00eb8eadba343e730eb4ac8e74326ac4842445932ee697577a7e823fbdc071 luau-0.507.tar.gz"