aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lxd/APKBUILD')
-rw-r--r--testing/lxd/APKBUILD139
1 files changed, 0 insertions, 139 deletions
diff --git a/testing/lxd/APKBUILD b/testing/lxd/APKBUILD
deleted file mode 100644
index d116bd2ccef..00000000000
--- a/testing/lxd/APKBUILD
+++ /dev/null
@@ -1,139 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=lxd
-pkgver=4.20
-pkgrel=0
-pkgdesc="a container hypervisor and a new user experience for LXC"
-url="https://linuxcontainers.org/lxd/"
-arch="all !mips !mips64"
-license="Apache-2.0"
-pkggroups="$pkgname"
-depends="
- acl
- attr
- netcat-openbsd
- cgmanager
- squashfs-tools
- rsync
- dqlite
- shadow-uidmap
- lxc
- ip6tables
- dnsmasq
- ca-certificates
- tar
- iproute2
- xz
- "
-makedepends="
- lxc-dev
- gettext-dev
- acl-dev
- acl-static
- tcl-dev
- libuv-dev
- eudev-dev
- libcap-dev
- linux-headers
-
- rsync
- go
- intltool
-
- libtool
- autoconf
- automake
- patchelf
- dqlite-dev
- dqlite-static
- lz4-dev
- sqlite-dev
- sqlite-static
- raft-dev
- raft-static
- gettext-static
- zlib-static
- libuv-static
- libseccomp-static
- libcap-static
- "
-subpackages="
- $pkgname-scripts:scripts:noarch
- $pkgname-bash-completion
- $pkgname-openrc
- $pkgname-doc
- "
-install="$pkgname.pre-install"
-options="!check"
-source="https://linuxcontainers.org/downloads/lxd/lxd-$pkgver.tar.gz
- $pkgname.confd
- $pkgname.initd
- "
-ldpath="/usr/lib/lxd"
-sonameprefix="$pkgname:"
-
-build() {
- export GOPATH="$builddir/_dist"
- export GOFLAGS="$GOFLAGS -buildmode=pie -trimpath"
- export CGO_LDFLAGS="-lintl $LDFLAGS"
- export CGO_LDFLAGS_ALLOW="(-Wl,-wrap,pthread_create)|(-Wl,-z,now)"
- export GO111MODULE=on
-
- mkdir -p bin
- go build -v -tags "netgo" -ldflags '-extldflags "-static -lm -ldl -lz -lpthread -lz -lintl -lraft -ldqlite -luv -lseccomp -lcap"' -o bin/ ./lxd-p2c/...
- go build -v -tags "agent" -ldflags '-extldflags "-static -lm -ldl -lz -lpthread -lz -lintl -lraft -ldqlite -luv -lseccomp -lcap"' -o bin/ ./lxd-agent/...
-
- for tool in fuidshift lxc lxc-to-lxd lxd lxd-benchmark; do
- go build -v -tags "libsqlite3" -o bin/ ./$tool/...
- done
-}
-
-package() {
- for tool in lxc fuidshift lxc-to-lxd lxd lxd-benchmark lxd-p2c lxd-agent; do
- install -p -Dm755 "bin/$tool" "$pkgdir/usr/bin/$tool"
- done
- install -Dm755 bin/$pkgname "$pkgdir"/usr/sbin/$pkgname
- install -Dm755 bin/lxc "$pkgdir"/usr/bin/lxc
-
- patchelf --set-rpath "/usr/lib/lxd" "$pkgdir/usr/sbin/lxd"
-
- install -Dm755 "$srcdir"/lxd.initd \
- "$pkgdir"/etc/init.d/lxd
- install -Dm644 "$srcdir"/lxd.confd \
- "$pkgdir"/etc/conf.d/lxd
-
- mkdir -p "$pkgdir"/var/lib/lxd
- chmod 755 "$pkgdir"/var/lib/lxd
- chgrp $pkggroups "$pkgdir"/var/lib/lxd
-
- mkdir -p "$pkgdir/usr/share/doc/$pkgname"
- cat > "$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
------------------------------------
-Be sure to add your local user to the lxd group.
-EOF
-}
-
-bashcomp() {
- depends="bash"
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- cd $builddir
- mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
- cp scripts/bash/lxd-client "$subpkgdir"/usr/share/bash-completion/completions/lxd-client
-}
-
-scripts() {
- pkgdesc="LXD scripts"
- depends="$pkgname py3-lxc jq"
-
- cd $builddir
- export GOPATH="$builddir/_dist"
- install -Dm755 scripts/empty-lxd.sh "$subpkgdir"/usr/bin/empty-lxd.sh
-}
-
-sha512sums="
-af8639e93f719a6aa1e37e7dafb5c221230470eb7a565422e6d1f6540e1d4250c00549831a17abbf3d4252bd473b71469bbbc93c7afcde68704d6a401967ed72 lxd-4.20.tar.gz
-1bbb26a61b3812e6eb4c3cb7db6c2d9adb43195f96f317d6bba1ace6a97f1faed0677a12c3827002bc147edba9b355f0e7ead3960d254a131b25fb8c060ea8d0 lxd.confd
-ebf9608ea3db25b456a557c81838c6a793adf5f490bd64e1f3dc6951bad619188cb0170f0a794b086adbd128267b4339ab46c1b6a815a4ae7f3a6566b7854d97 lxd.initd
-"