aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxqt-about/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lxqt-about/APKBUILD')
-rw-r--r--testing/lxqt-about/APKBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/testing/lxqt-about/APKBUILD b/testing/lxqt-about/APKBUILD
deleted file mode 100644
index 9b1c707a2b6..00000000000
--- a/testing/lxqt-about/APKBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
-pkgname=lxqt-about
-pkgver=0.17.0
-pkgrel=0
-pkgdesc="Information provider about LXQt and the system"
-url="https://github.com/lxqt/lxqt-about"
-arch="all !armhf" # armhf blocked by liblxqt and kwindowsystem
-arch="$arch !mips64" # mips64 blocked by liblxqt
-license="LGPL-2.0-or-later"
-makedepends="
- cmake lxqt-build-tools liblxqt-dev
- kwindowsystem-dev qt5-qttools-dev
- "
-options="!check" # No testsuite
-source="https://github.com/lxqt/lxqt-about/releases/download/$pkgver/lxqt-about-$pkgver.tar.xz"
-
-build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- $CMAKE_CROSSOPTS .
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-sha512sums="
-d347db528a267b857279a96fba31ebfcb1468603cb16c6f002d1675ddf351524f6a93d811f2f980dafd2c46db4a2a86b4521ce82157050dd3166f74c771c4367 lxqt-about-0.17.0.tar.xz
-"