aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxqt-archiver/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lxqt-archiver/APKBUILD')
-rw-r--r--testing/lxqt-archiver/APKBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/testing/lxqt-archiver/APKBUILD b/testing/lxqt-archiver/APKBUILD
deleted file mode 100644
index 12ab29533e7..00000000000
--- a/testing/lxqt-archiver/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
-pkgname=lxqt-archiver
-pkgver=0.5.0
-pkgrel=0
-pkgdesc="Simple and lightweight desktop-agnostic Qt file archiver"
-url="https://github.com/lxqt/lxqt-archiver"
-arch="all !s390x !armhf !mips64" # s390x blocked by libfm-qt
-license="LGPL-2.0-or-later"
-makedepends="
- cmake lxqt-build-tools qt5-qttools-dev qt5-qtx11extras-dev
- libfm-qt-dev json-glib-dev menu-cache-dev libexif-dev
- "
-options="!check" # No testsuite
-source="https://github.com/lxqt/lxqt-archiver/releases/download/$pkgver/lxqt-archiver-$pkgver.tar.xz"
-
-build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- $CMAKE_CROSSOPTS .
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-sha512sums="
-01747499fece79010f359bfe5987dd0ef96daa92269659dc64543a78a4540ed7e5ff2e0b2ae6ab620c6be7244f4e350a18aa08657e7d84429fa20d0a264977c6 lxqt-archiver-0.5.0.tar.xz
-"