aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lxqt-build-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lxqt-build-tools/APKBUILD')
-rw-r--r--testing/lxqt-build-tools/APKBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/testing/lxqt-build-tools/APKBUILD b/testing/lxqt-build-tools/APKBUILD
deleted file mode 100644
index 10a05078ff7..00000000000
--- a/testing/lxqt-build-tools/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
-# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
-# Contributor: Antoni Aloy <aaloytorrens@gmail.com>
-pkgname=lxqt-build-tools
-pkgver=0.9.0
-pkgrel=0
-pkgdesc="Various packaging tools and scripts for LXQt applications"
-url="https://lxqt.org/"
-options="!check" # No testsuite
-arch="noarch"
-license="BSD-3-Clause"
-makedepends="cmake qt5-qtbase-dev glib-dev"
-source="https://github.com/lxde/lxqt-build-tools/releases/download/$pkgver/lxqt-build-tools-$pkgver.tar.xz"
-
-build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- $CMAKE_CROSSOPTS .
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-
-sha512sums="
-9a464393ea6d871c5856ebf5b8fa3d31a89c6419ac084e7146aed675f2b20a139bb3eedde017d6ca03167ee6e30a37a62239ab4e8b76f5b6db244d26ab164892 lxqt-build-tools-0.9.0.tar.xz
-"