aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mat2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mat2/APKBUILD')
-rw-r--r--testing/mat2/APKBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/testing/mat2/APKBUILD b/testing/mat2/APKBUILD
index acac71095dd..d733ca470c8 100644
--- a/testing/mat2/APKBUILD
+++ b/testing/mat2/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Waweic <waweic@activ.ism.rocks>
# Contributor: Waweic <waweic@activ.ism.rocks>
pkgname=mat2
-pkgver=0.12.4
-pkgrel=0
+pkgver=0.13.4
+pkgrel=1
pkgdesc="Metadata removal tool, supporting a wide range of commonly used file formats"
url="https://0xacab.org/jvoisin/mat2"
arch="noarch !s390x !riscv64" #librsvg missing for s390x and riscv64
@@ -20,8 +20,18 @@ depends="
"
makedepends="py3-setuptools"
checkdepends="ffmpeg"
-source="https://0xacab.org/jvoisin/mat2/-/archive/$pkgver/mat2-$pkgver.tar.gz"
-subpackages="$pkgname-doc"
+source="https://0xacab.org/jvoisin/mat2/-/archive/$pkgver/mat2-$pkgver.tar.gz
+ manpage-dir.patch
+ "
+subpackages="$pkgname-doc $pkgname-pyc"
+
+prepare() {
+ default_prepare
+
+ # doesn't contain a version in [project], so it's invalid to parse from a
+ # builder, # but we can ignore all that as all the logic is in setup.*
+ rm -fv pyproject.toml
+}
build() {
python3 setup.py build
@@ -33,10 +43,10 @@ check() {
package() {
python3 setup.py install --skip-build --prefix=/usr --root="$pkgdir"
- install -Dm 644 doc/mat2.1 -t "$pkgdir/usr/share/man/man1"
install -Dm 644 doc/*.md -t "$pkgdir/usr/share/doc/$pkgname"
}
sha512sums="
-20936c80d0fa31dae9ee14c3d853c0e63a87b2d3ad5838a17bdbbc3e7cb4cf73462c9a9573d2aeab6e4ab0d6c18ce24c63a80e1a7cd044724c8ecc639d13da80 mat2-0.12.4.tar.gz
+75c08c9c52a82f9983e799c2aeef0da8324d1c92ac32fb748a68063ec7b28569692082aceacf7161d24db0e8a988357c423b6e17ca5c0f934309c9791c41ab18 mat2-0.13.4.tar.gz
+2bf84ae9fab848fea43c87b708937628c2d5e74cb4f0457ef259356c651056eea1a0d033d606fc5511f195cbb5a097c21e631a9a4973431c8f3242a1969d9123 manpage-dir.patch
"