aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mediastreamer2-plugin-openh264/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mediastreamer2-plugin-openh264/APKBUILD')
-rw-r--r--testing/mediastreamer2-plugin-openh264/APKBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/testing/mediastreamer2-plugin-openh264/APKBUILD b/testing/mediastreamer2-plugin-openh264/APKBUILD
index a180673f5bc..37414b34a5d 100644
--- a/testing/mediastreamer2-plugin-openh264/APKBUILD
+++ b/testing/mediastreamer2-plugin-openh264/APKBUILD
@@ -1,35 +1,33 @@
# Contributor: Martin Schmidt <martin.schmidt13@gmx.de>
# Maintainer: Martin Schmidt <martin.schmidt13@gmx.de>
-_commit=2c3abf52824ad23a4caae7565ef158ef91767704
pkgname=mediastreamer2-plugin-openh264
-pkgver=1.2.1_git20200309
+pkgver=5.2.0_git20231020
+_commit=ed96173dc74ca48e700cafea53f1d49575d84c70
pkgrel=0
pkgdesc="An H.264 encoder/decoder plugin for mediastreamer2 based on the openh264 library"
url="https://gitlab.linphone.org/BC/public/msopenh264"
arch="all"
license="GPL-2.0-or-later"
options="!check" # no test available
-makedepends="cmake ortp-dev bctoolbox-dev mediastreamer2-dev openh264-dev"
-
-source="$pkgname-$_commit.tar.gz::https://gitlab.linphone.org/BC/public/msopenh264/-/archive/$_commit.tar.gz
-"
-
+makedepends="
+ bctoolbox-dev
+ cmake
+ mediastreamer2-dev
+ openh264-dev
+ ortp-dev
+ samurai
+ "
+source="$pkgname-$_commit.tar.gz::https://gitlab.linphone.org/BC/public/msopenh264/-/archive/$_commit.tar.gz"
builddir="$srcdir/msopenh264-$_commit"
-prepare() {
- default_prepare
- sed -i 's/ORTP\ REQUIRED/ortp\ REQUIRED/g' src/CMakeLists.txt
-}
-
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_MODULE_PATH=/usr/lib/cmake \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
- -DENABLE_STRICT=NO \
- -DENABLE_SHARED=YES
+ -DBUILD_SHARED_LIBS=YES
cmake --build build
}
@@ -37,4 +35,7 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="7a62edd688a1336aee8f30d72b8e8d5bee62e68e02a23cfc4c043af07e8f231a247ce5a817538abe6f61956cb11567752b15228b57ef3f67a5125789328d3897 mediastreamer2-plugin-openh264-2c3abf52824ad23a4caae7565ef158ef91767704.tar.gz"
+
+sha512sums="
+c4487675b7ea16ed4a967d0cbc0a9c3e8aff8e0832805b9a3fb2f38d836008663f68c37253f04d04237b306e709c357e19c34598242cc9fcdbe7bbdce57e9d3c mediastreamer2-plugin-openh264-ed96173dc74ca48e700cafea53f1d49575d84c70.tar.gz
+"