aboutsummaryrefslogtreecommitdiffstats
path: root/testing/metalang99/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/metalang99/APKBUILD')
-rw-r--r--testing/metalang99/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/metalang99/APKBUILD b/testing/metalang99/APKBUILD
new file mode 100644
index 00000000000..fa2cf514cea
--- /dev/null
+++ b/testing/metalang99/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Sebastian Hudak <sebastian@sebsite.pw>
+# Maintainer: Sebastian Hudak <sebastian@sebsite.pw>
+pkgname=metalang99
+pkgver=1.13.3
+pkgrel=0
+pkgdesc="C meta-programming language built with pre-processor macros"
+url="https://github.com/Hirrolot/metalang99"
+arch="noarch"
+license="MIT"
+checkdepends="bash cmake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Hirrolot/metalang99/archive/v$pkgver.tar.gz"
+
+check() {
+ scripts/test.sh
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr
+ cp -r include "$pkgdir"/usr/include
+}
+
+sha512sums="
+dae829981780995fd3fbb1c2921a57fd560a3e1ad2af5df1654bc555a77aa15287b33ce064fd0914b50869aceb959f567ed79d4b00249ef814973756fc9c5ff1 metalang99-1.13.3.tar.gz
+"