aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mgba
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mgba')
-rw-r--r--testing/mgba/APKBUILD24
-rwxr-xr-x[-rw-r--r--]testing/mgba/test-py.sh0
2 files changed, 12 insertions, 12 deletions
diff --git a/testing/mgba/APKBUILD b/testing/mgba/APKBUILD
index 7bdb8cf78d9..84601282383 100644
--- a/testing/mgba/APKBUILD
+++ b/testing/mgba/APKBUILD
@@ -7,16 +7,14 @@ pkgdesc="Game Boy Advance Emulator"
url="https://github.com/mgba-emu/mgba"
arch="all"
license="MPL-2.0"
-depends=""
-depends_dev=""
makedepends="cmake qt5-qtmultimedia-dev qt5-qtbase-dev qt5-qttools-dev
sdl-dev libzip-dev zlib-dev libpng-dev ffmpeg-dev imagemagick-dev
libepoxy-dev cmocka-dev libedit-dev py3-virtualenv python3-dev"
checkdepends="py3-cffi py3-cached-property"
-install=""
subpackages="$pkgname-doc $pkgname-py:_py"
source="mgba-$pkgver.tar.gz::https://github.com/mgba-emu/mgba/archive/$pkgver.tar.gz
http://gbdev.gg8.se/files/roms/blargg-gb-tests/cpu_instrs.zip
+ test-py.sh
no-rpath.patch
python3.patch
mgba-qt.desktop"
@@ -49,7 +47,7 @@ check() {
PYTHONPATH="$PWD/$(echo python/lib.linux-x86_64-3.*)" \
LD_LIBRARY_PATH="$builddir/build" \
ZIPFILE="$srcdir/cpu_instrs.zip" \
- /bin/sh "$startdir/test-py.sh"
+ "$startdir/test-py.sh"
}
package() {
@@ -61,25 +59,27 @@ package() {
rm "$pkgdir/usr/bin/tbl-fuzz"
# add desktop file
- local _apps="$pkgdir/usr/share/applications"
- mkdir -p "$_apps"
- cp "$startdir/mgba-qt.desktop" "$_apps"/
+ local apps="$pkgdir/usr/share/applications"
+ mkdir -p "$apps"
+ cp "$startdir/mgba-qt.desktop" "$apps"/
}
_py() {
+ pkgdesc="Python3 bindings for the mGBA emulator"
depends="py3-cffi py3-cached-property"
cd "$builddir/build/python"
- local _bdir=$(echo lib.linux-x86_64-3.*)
- local _pyver=${_bdir##*-}
- local _dest="$subpkgdir/usr/lib/python$_pyver/site-packages"
+ local bdir=$(echo lib.linux-x86_64-3.*)
+ local pyver=${bdir##*-}
+ local dest="$subpkgdir/usr/lib/python$pyver/site-packages"
- mkdir -p "$_dest"
- mv $_bdir/mgba/ "$_dest/"
+ mkdir -p "$dest"
+ mv $bdir/mgba/ "$dest/"
}
sha512sums="d646af7869dbcf8df671a75ecfd8c270950c013b826b23b94bacae43a77243786f198725e1b9bf17827d1ffcf6a8eef70091d53ea878bfb2450472485f42f233 mgba-0.6.3.tar.gz
ea4a1de976e2188c3720d7b8e6f75f67feaede37473826343f9b0a03fe76405e84305384ceee1bc56a4e8131cab432b63320d4c0b120a6c81425af8f0bfbd234 cpu_instrs.zip
+239d985e6379495569bcc5c9fe15ab913585029d9979cc6b2cdd23ff49cb1426f9b90c763b3314cac888c599951e54c2584ee69280158b615aa64ad188f1e1ad test-py.sh
8fefd97e66b63bc660abab2a5d0f29b96b41022e12e53af9841c97dd8d74dddde9c1ac7b56a7f5d7346aa42671767ce3794ecccf66142262116e740a21f6ef03 no-rpath.patch
7e2ac69620f0118d429afbb6ae905be1e81c80c5eb83118b74ab65f3db81f25823098475d32add624e4424fdac0f882f18c4b42673719eb278160805330148c8 python3.patch
f77d1e3a35521f29e9caaebb6b010e497602a467963b95b155f67d39c129d8a1bd6acdbce1a10bf25e68ac38de0e4079deb92c710afccc8a2c4841820d3f9119 mgba-qt.desktop"
diff --git a/testing/mgba/test-py.sh b/testing/mgba/test-py.sh
index af47e0a7c92..af47e0a7c92 100644..100755
--- a/testing/mgba/test-py.sh
+++ b/testing/mgba/test-py.sh