aboutsummaryrefslogtreecommitdiffstats
path: root/testing/micropython/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/micropython/APKBUILD')
-rw-r--r--testing/micropython/APKBUILD51
1 files changed, 31 insertions, 20 deletions
diff --git a/testing/micropython/APKBUILD b/testing/micropython/APKBUILD
index 7d8593194b7..0f2f493f6b0 100644
--- a/testing/micropython/APKBUILD
+++ b/testing/micropython/APKBUILD
@@ -1,27 +1,34 @@
# Contributor: Marian <marian.buschsieweke@ovgu.de>
# Maintainer: Marian <marian.buschsieweke@ovgu.de>
pkgname=micropython
-pkgver=1.14
+pkgver=1.22.1
+_mpy_lib_ver=1.22.0
pkgrel=0
pkgdesc="lean and efficient Python implementation for MCUs and constrained systems"
url="https://www.micropython.org/"
-# ppc64le: mpy-cross fails to compile with "unsupported relocation type 4"
-# armv7: 17 unit tests fail, mostly viper related
-# armhf: fails to build
-# s390x: sporadic test failures: "2 tests failed: repl_cont uasyncio_heaplock"
-arch="all !ppc64le !armv7 !armhf !s390x"
+# ppc64le: mpy-cross fails to compile with "unsupported relocation type 4 & 5"
+# armhf: fails to build due to "error compiling argparse.py"
+arch="all !ppc64le !armhf"
license="MIT"
makedepends="libffi-dev python3"
subpackages="$pkgname-cross"
-source="micropython-$pkgver.tar.gz::https://github.com/micropython/micropython/archive/v$pkgver.tar.gz
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/micropython/micropython/archive/refs/tags/v$pkgver.tar.gz
+ micropython-lib-$_mpy_lib_ver.tar.gz::https://github.com/micropython/micropython-lib/archive/refs/tags/v$_mpy_lib_ver.tar.gz
micropython-1.9.4-prevent-stripping.patch
- no_ussl.patch
+ no_ssl.patch
no_legacy_berkeley_db.patch
- fix_clobbered_longjmp.patch
+ no-werror.patch
"
+prepare() {
+ default_prepare
+ rmdir lib/micropython-lib
+ ln -s ../../micropython-lib-$_mpy_lib_ver lib/micropython-lib
+}
+
build() {
make -C mpy-cross PYTHON=python3
make -C ports/unix PYTHON=python3
@@ -38,26 +45,30 @@ check() {
;;
esac
- # ffi callback fails on kernel with PaX
- rm tests/unix/ffi_callback.py
+ # Needed for tests/extmod/select_poll_fd.py to
+ # pass (see comment in that file for more info)
+ ulimit -n 1024
make -C ports/unix test PYTHON=python3
}
package() {
- mkdir -p "$pkgdir/usr/bin"
- install -m755 ports/unix/micropython "$pkgdir/usr/bin/micropython"
+ install -Dm755 -t "$pkgdir"/usr/bin \
+ ports/unix/build-standard/micropython \
+ mpy-cross/build/mpy-cross
}
cross() {
pkgdesc="Compile micropython code to bytecode, which can be transfered to MCUs"
- cd "$builddir"
- mkdir -p "$subpkgdir/usr/bin"
- install -m755 mpy-cross/mpy-cross "$subpkgdir/usr/bin/mpy-cross"
+
+ amove usr/bin/mpy-cross
}
-sha512sums="6a6a8fc0306e651aca81a67d09ca7bc4d94f655056ff76b09f8913e88daac30e5f74d486dd5ad8bd5ebdf81115cf1d88a9b21f118516352a5c8023fb44370792 micropython-1.14.tar.gz
-8f994394f42d7fed5fa35b62c01c37ebea3b487c029d659134a263ef8d65e1ec17bec755fdf57cde2f234969bc4f7f4ab30858562d7f8cdb2bc6cb819ba2ae0d micropython-1.9.4-prevent-stripping.patch
-9a6cd131c8875a9d320653b7b93d46a759eee3255e25763eb8de6934b3035f691e497eafc9412320f13c5921a384d42d6e60ea3eb3d65f3a6101dae9be514f3c no_ussl.patch
+sha512sums="
+df4220a360f38b865e128fe23d8082eec1ed30cd80d5c94ea957de59e5ba67b766852b26a068c4abb672448012336fbab988f810a95cb4f4dc49055158f30a2f micropython-1.22.1.tar.gz
+fb46625b038c649c98fe0929a8f8fb6c01495614942942a7c92b90679f07c39ad7142c966a7643538d529c356b00f483308a33ac00d441fb662dd3a3dd3c418d micropython-lib-1.22.0.tar.gz
+47f4923b1901bf0c8c90a15fe7188ae5c07d4c451d129c271d52d9449ac6094bf7183d5c4dc9cb38d5d5b4bf6944a715b7a3377575e9bc92bee16801d8088436 micropython-1.9.4-prevent-stripping.patch
+6e13449a4d273538d9d752de88a292ff15ef035ca55abc8c5ee4b396d3088c292f059e59a9b17594d02393a0deb28f309d6fde057ba9c2bd91e58b99f55d7c97 no_ssl.patch
e86ad02ef746605f2f685ae776a6ad6ea39ae6e57fa0869a0c03895fd581647de20fa7e6aaeebac45e7302a63451d625208b1356ee2f35a66df70ac2755a25ff no_legacy_berkeley_db.patch
-a326877348391e1d87ec6209274dd68de3775fd64d209a2ac7f13ce860e74255107a0fbe5fa555eda5a28885d9b8ce7886d9f2012242ec6da83fac464bbc6706 fix_clobbered_longjmp.patch"
+99a021dc8fe8f7cd26455e9e7610e36bfb3c01182b42855a6cc3453dea29ea25fe622c3d722a71f973a1382446f6434260cc2a986d92895e187e784c57069b31 no-werror.patch
+"