aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mimalloc1/cmake-add-insecure-suffix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mimalloc1/cmake-add-insecure-suffix.patch')
-rw-r--r--testing/mimalloc1/cmake-add-insecure-suffix.patch27
1 files changed, 17 insertions, 10 deletions
diff --git a/testing/mimalloc1/cmake-add-insecure-suffix.patch b/testing/mimalloc1/cmake-add-insecure-suffix.patch
index cb54fbd3f13..a0e4abb7a2b 100644
--- a/testing/mimalloc1/cmake-add-insecure-suffix.patch
+++ b/testing/mimalloc1/cmake-add-insecure-suffix.patch
@@ -1,12 +1,16 @@
+Updated: 20 Feb 2021 by Nicolas Lorin <androw95220@gmail.com>
+
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Thu, 19 Aug 2021 23:08:13 +0200
Subject: Add suffix "-insecure" to library with MI_SECURE=OFF
We want to make the secure variant the default one.
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0011b87..bda3d5e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -56,11 +56,6 @@
+@@ -67,11 +67,6 @@ if (NOT CMAKE_BUILD_TYPE)
endif()
endif()
@@ -15,21 +19,24 @@ We want to make the secure variant the default one.
- set(MI_SECURE "ON")
-endif()
-
+
# -----------------------------------------------------------------------------
# Process options
- # -----------------------------------------------------------------------------
-@@ -220,12 +215,12 @@
+@@ -313,6 +308,8 @@ endif()
+ set(mi_basename "mimalloc")
if(MI_SECURE)
- set(mi_basename "mimalloc-secure")
- else()
-- set(mi_basename "mimalloc")
-+ set(mi_basename "mimalloc-insecure")
+ set(mi_basename "${mi_basename}-secure")
++else()
++ set(mi_basename "${mi_basename}-insecure")
+ endif()
+ if(MI_VALGRIND)
+ set(mi_basename "${mi_basename}-valgrind")
+@@ -322,7 +319,7 @@ if(MI_ASAN)
endif()
-
string(TOLOWER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_LC)
- if(NOT(CMAKE_BUILD_TYPE_LC MATCHES "^(release|relwithdebinfo|minsizerel)$"))
+ if(NOT(CMAKE_BUILD_TYPE_LC MATCHES "^(release|relwithdebinfo|minsizerel|none)$"))
- set(mi_basename "${mi_basename}-${CMAKE_BUILD_TYPE_LC}") #append build type (e.g. -debug) if not a release version
+ set(mi_basename "mimalloc-${CMAKE_BUILD_TYPE_LC}") #append build type (e.g. -debug) if not a release version
endif()
+
if(MI_BUILD_SHARED)
- list(APPEND mi_build_targets "shared")