aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mimalloc2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mimalloc2/APKBUILD')
-rw-r--r--testing/mimalloc2/APKBUILD94
1 files changed, 0 insertions, 94 deletions
diff --git a/testing/mimalloc2/APKBUILD b/testing/mimalloc2/APKBUILD
deleted file mode 100644
index b3f1ee20d40..00000000000
--- a/testing/mimalloc2/APKBUILD
+++ /dev/null
@@ -1,94 +0,0 @@
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=mimalloc2
-_projname=mimalloc
-pkgver=2.0.2_beta
-_pkgver=${pkgver%_*}
-pkgrel=0
-_pkgdesc="A compact general purpose allocator with excellent performance"
-pkgdesc="$_pkgdesc (in secure mode)"
-url="https://github.com/microsoft/mimalloc"
-# aarch64,arm*: tests fail
-arch="all !aarch64 !armhf !armv7"
-license="MIT"
-makedepends="cmake"
-provides="mimalloc=$pkgver-r$pkgrel"
-provider_priority=0 # lowest
-subpackages="$pkgname-dev $pkgname-insecure $pkgname-debug"
-source="https://github.com/microsoft/mimalloc/archive/v$_pkgver/$_projname-$_pkgver.tar.gz
- cmake-install-paths.patch
- cmake-add-insecure-suffix.patch
- "
-builddir="$srcdir/$_projname-$_pkgver"
-
-_buildtypes='debug insecure secure'
-
-build() {
- _build out/debug -DCMAKE_BUILD_TYPE=Debug -DMI_DEBUG_FULL=ON
-
- # This is called "release" build by upstream.
- _build out/insecure -DCMAKE_BUILD_TYPE=Release -DMI_SECURE=OFF
-
- _build out/secure -DCMAKE_BUILD_TYPE=Release -DMI_SECURE=ON
-}
-
-_build() {
- local outdir="$1"; shift
-
- local crossopts=
- [ "$CBUILD" = "$CHOST" ] \
- || crossopts='-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux'
-
- CFLAGS=${CFLAGS/-Os/} cmake -B "$outdir" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
- $crossopts \
- "$@" .
- cmake --build "$outdir"
-}
-
-check() {
- local btype; for btype in $_buildtypes; do
- msg "Testing $btype build"
-
- cd "$builddir"/out/$btype
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest --timeout 300
- done
-}
-
-package() {
- local btype; for btype in $_buildtypes; do
- DESTDIR="$pkgdir" cmake --install out/$btype
- done
-
- cd "$pkgdir"
- ln -s libmimalloc-secure.so usr/lib/libmimalloc.so
- ln -s libmimalloc-secure.so.${pkgver%.*} usr/lib/libmimalloc.so.${pkgver%.*}
- ln -s libmimalloc-secure.a usr/lib/libmimalloc.a
-
- sed 's/-secure/-insecure/g' usr/lib/cmake/mimalloc/mimalloc-release.cmake \
- > usr/lib/cmake/mimalloc/mimalloc-insecure.cmake
- mv usr/lib/cmake/mimalloc/mimalloc-release.cmake usr/lib/cmake/mimalloc/mimalloc-secure.cmake
- ln -s mimalloc-secure.cmake usr/lib/cmake/mimalloc/mimalloc-release.cmake
-
- rm -f usr/lib/*.o
-}
-
-insecure() {
- pkgdesc="$_pkgdesc (in insecure mode)"
-
- amove usr/lib/libmimalloc-insecure.*
-}
-
-debug() {
- pkgdesc="$_pkgdesc (debug build)"
- options="!strip"
-
- amove usr/lib/libmimalloc-debug.*
-}
-
-sha512sums="
-d6f1749a6df86346220fc190a3fd6aa67deff5439b26846c33ff95e91ce5fea73837ee39348dd432db3592575298e6e87856329d0236d2c6959abd8bf7756cdc mimalloc-2.0.2.tar.gz
-587b7e3cdd7284f54642a32c8eb777ae6351da0a53919fc8821144991bc6e1fb1c954debb41ada914b3ef02bd1f29655fabee0c3ffdbe013fe573a3864323f56 cmake-install-paths.patch
-a2011dd2d229b048a39751219a4e0e44c5bac11bd0aa615c51e34ca9044e491822d5020d038a78c2c75c3b44657e4c2b6b62721569960834c722bc5eb2297dc2 cmake-add-insecure-suffix.patch
-"