aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mitmproxy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mitmproxy/APKBUILD')
-rw-r--r--testing/mitmproxy/APKBUILD55
1 files changed, 30 insertions, 25 deletions
diff --git a/testing/mitmproxy/APKBUILD b/testing/mitmproxy/APKBUILD
index 9c3631885d5..3acec9de8f6 100644
--- a/testing/mitmproxy/APKBUILD
+++ b/testing/mitmproxy/APKBUILD
@@ -1,30 +1,31 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Contributor: Michał Polański <michal@polanski.me>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Michał Polański <michal@polanski.me>
pkgname=mitmproxy
-pkgver=7.0.4
-pkgrel=2
+pkgver=10.2.0
+pkgrel=0
pkgdesc="Interactive TLS-capable intercepting HTTP proxy"
url="https://mitmproxy.org/"
license="MIT"
-arch="noarch !s390x !armhf" # limited by py3-zstandard
+# armhf, s390x: limited by py3-zstandard
+# ppc64le, riscv64, s390x: limited by py3-mitmproxy-rs
+arch="noarch !armhf !ppc64le !riscv64 !s390x"
depends="
- python3
+ py3-aioquic
py3-asgiref
- py3-blinker
py3-brotli
py3-certifi
- py3-click
py3-cryptography
py3-flask
+ py3-h11
py3-h2
py3-hyperframe
py3-kaitaistruct
py3-ldap3
+ py3-mitmproxy-rs
py3-msgpack
py3-passlib
py3-protobuf
- py3-asn1
py3-openssl
py3-parsing
py3-pyperclip
@@ -36,7 +37,12 @@ depends="
py3-publicsuffix2
py3-zstandard
"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="
py3-hypothesis
py3-parver
@@ -44,37 +50,36 @@ checkdepends="
py3-pytest-asyncio
py3-requests
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mitmproxy/mitmproxy/archive/v$pkgver.tar.gz
+subpackages="$pkgname-pyc"
+source="https://github.com/mitmproxy/mitmproxy/archive/$pkgver/mitmproxy-$pkgver.tar.gz
skip-test-optmanager-x86.patch
+ fix-openssl-tests.patch
"
# secfixes:
# 7.0.3-r0:
# - CVE-2021-39214
-prepare() {
- default_prepare
- # remove test file importing asynctest module, which doesn't support python3.8
- # see: https://github.com/Martiusweb/asynctest/issues/132
- rm test/mitmproxy/addons/test_readfile.py
-
- # relax constraints on required dependencies
- sed -E "s/, *<[0-9=.]*//" -i setup.py
-}
-
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest --deselect "test/mitmproxy/test_version.py::test_get_version"
+ pytest \
+ --deselect "test/mitmproxy/test_version.py::test_get_version" \
+ --deselect "test/mitmproxy/proxy/test_mode_servers.py::test_wireguard" \
+ --deselect "test/mitmproxy/addons/test_script.py::test_order"
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 -m installer -d "$pkgdir" \
+ .dist/mitmproxy-$pkgver-py3-none-any.whl
}
sha512sums="
-4224b44e609f84b974b5419c6ceb576845957968c786ee437bffb5fa5df685ce0712d5ef8c402d40c568406242f44692cc7f04037fadd19ecece8b112d73b7ae mitmproxy-7.0.4.tar.gz
-30d677fe7899394e096d20f16d5522dc962518bebf4e23eaa954507a2dd99af61e568e6515363c74fd606d43cce21bc4c3272c6f08d2cf97d88981449cf9d1a2 skip-test-optmanager-x86.patch
+dde49756394b6ea0c69e791f0ffe579d8ba2b0a321032af8700a4ba3d1a26039e477f24523fb34229faf0e9c71a29530938c8f302dc9131a674f4cb47a57f0c3 mitmproxy-10.2.0.tar.gz
+1baa88dae9f664af4bed62f89a7f5d13685b42774ea19563eba7298ef09fa07fafb4d5f1650e044561a5d304451d916e6c9833ad9755204d424bea6ed3bdb4fd skip-test-optmanager-x86.patch
+7f37bcff3ea870224075f18745e382c9ba8bd3c8697be11d0eccf458a5f4eecdda097c2ae790f6f5db796512c03fb78988d3e96cbde5aac6cef6a8b8b767faab fix-openssl-tests.patch
"