aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mkdocs-windmill/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mkdocs-windmill/APKBUILD')
-rw-r--r--testing/mkdocs-windmill/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/mkdocs-windmill/APKBUILD b/testing/mkdocs-windmill/APKBUILD
new file mode 100644
index 00000000000..cfc9f8b6edb
--- /dev/null
+++ b/testing/mkdocs-windmill/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=mkdocs-windmill
+pkgver=1.0.5
+pkgrel=3
+pkgdesc="MkDocs theme focused on navigation and usability"
+url="https://github.com/gristlabs/mkdocs-windmill"
+arch="noarch"
+license="MIT"
+depends="python3 mkdocs"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/m/$pkgname/$pkgname-$pkgver.tar.gz"
+options="!check" # No tests.
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+32093a10e1ef1eddba6de031556bcf53f7b8bb9ef911a5bde4b89aecb4733a1ec35cf9ec3d99b98b678b4d22f8958ef6da4e36b1fcac04fdf3cdc1a9a71766f0 mkdocs-windmill-1.0.5.tar.gz
+"