aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mkdocs-windmill/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mkdocs-windmill/APKBUILD')
-rw-r--r--testing/mkdocs-windmill/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/testing/mkdocs-windmill/APKBUILD b/testing/mkdocs-windmill/APKBUILD
index 30e317ad3d2..46ba45a3761 100644
--- a/testing/mkdocs-windmill/APKBUILD
+++ b/testing/mkdocs-windmill/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: David Demelier <markand@malikania.fr>
# Maintainer: David Demelier <markand@malikania.fr>
pkgname=mkdocs-windmill
-pkgver=1.0.4
-pkgrel=0
-pkgdesc="mkdocs theme focused on navigation and usability"
+pkgver=1.0.5
+pkgrel=2
+pkgdesc="MkDocs theme focused on navigation and usability"
url="https://github.com/gristlabs/mkdocs-windmill"
arch="noarch"
license="MIT"
-depends="python3"
+depends="python3 mkdocs"
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/m/mkdocs-windmill/mkdocs-windmill-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/m/$pkgname/$pkgname-$pkgver.tar.gz"
options="!check" # No tests.
build() {
@@ -17,9 +18,9 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-5e5e0fd580d2c6af7842a0c91549a59c71baf65cceaeafd453b141e33e1ea7ff8820c819413b2df04a6c969d9dba66ee963ffabb16cf7799463453207090f4c6 mkdocs-windmill-1.0.4.tar.gz
+32093a10e1ef1eddba6de031556bcf53f7b8bb9ef911a5bde4b89aecb4733a1ec35cf9ec3d99b98b678b4d22f8958ef6da4e36b1fcac04fdf3cdc1a9a71766f0 mkdocs-windmill-1.0.5.tar.gz
"