aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mm-common/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mm-common/APKBUILD')
-rw-r--r--testing/mm-common/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/mm-common/APKBUILD b/testing/mm-common/APKBUILD
new file mode 100644
index 00000000000..c10137f8970
--- /dev/null
+++ b/testing/mm-common/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Alex Yam <alex@alexyam.com>
+# Maintainer: Alex Yam <alex@alexyam.com>
+pkgname=mm-common
+pkgver=1.0.5
+pkgrel=0
+arch="noarch"
+pkgdesc="Build infrastructure and utilities for GNOME C++ binding libraries"
+options="!check" # No test suite
+url="https://gitlab.gnome.org/GNOME/mm-common"
+license="GPL-2.0-or-later"
+depends="
+ gtkmm3-dev
+ glibmm-dev
+ "
+makedepends="meson"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver-2.tar.xz::https://download.gnome.org/sources/mm-common/${pkgver%.*}/mm-common-$pkgver.tar.xz"
+
+build() {
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+bf681b4d63d5bf531a9315b0c8841e3815af276828d1828a3eb04dcb805cbbfbaac182f79f5e48688a7eef8666975b9079144e320093e4ee3addff48813e61ad mm-common-1.0.5-2.tar.xz
+"