aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mmix/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mmix/APKBUILD')
-rw-r--r--testing/mmix/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/mmix/APKBUILD b/testing/mmix/APKBUILD
new file mode 100644
index 00000000000..d0eacf1296a
--- /dev/null
+++ b/testing/mmix/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=mmix
+pkgver=0_git20221025
+pkgrel=0
+pkgdesc="Assembler and instruction level simulator for the MMIX platform"
+url="http://www.mmix.cs.hm.edu/exe/index.html"
+# ppc64le, s390x and riscv64 blocked by texlive
+arch="all !ppc64le !s390x !riscv64"
+license="custom"
+makedepends="texlive" # ctangle is needed to compile .w files
+_commit=013719105c56e0205e003f7f6ae5c3e1314da6bc
+source="$pkgname-$pkgver.tar.bz2::https://gitlab.lrz.de/mmix/mmixware/-/archive/$_commit/mmixware-$_commit.tar.bz2"
+builddir="$srcdir/mmixware-$_commit"
+options="!check" # contains no unit test suite
+
+build() {
+ # parallel build is broken. Luckily, this is quick to compile anyway
+ make all -j1
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm 755 mmix mmixal mmotype mmmix -t "$pkgdir/usr/bin"
+ install -Dm 644 -t "$pkgdir"/usr/share/licenses/$pkgname/ boilerplate.w
+}
+
+sha512sums="
+279e75ec798f0b168dc002accfc449d222def43b5f580d5d69bb0156f7f11613a880dc68eac554c4813708db5efd92fe70f6e0e7bdf3864eb69060f843a968e7 mmix-0_git20221025.tar.bz2
+"