aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mobpass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mobpass/APKBUILD')
-rw-r--r--testing/mobpass/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/mobpass/APKBUILD b/testing/mobpass/APKBUILD
index 554c7cb19d3..37e79be1654 100644
--- a/testing/mobpass/APKBUILD
+++ b/testing/mobpass/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=mobpass
pkgver=0.2
-pkgrel=2
+pkgrel=5
pkgdesc="A mobile interface for gopass"
url="https://git.sr.ht/~anjan/mobpass"
-arch="noarch !mips64 !armhf" # missing dependencies
+arch="noarch !armhf" # missing dependencies
options="!check" # No test suite
license="GPL-3.0-or-later"
depends="python3 py3-qt5 qt5-qtquickcontrols qt5-qtquickcontrols2 gopass py3-fuzzyfinder"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~anjan/mobpass/archive/v$pkgver.tar.gz"
builddir="$srcdir/"$pkgname-v$pkgver
@@ -18,7 +19,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
install -Dm644 mobpass.desktop "$pkgdir"/usr/share/applications/mobpass.desktop
}