aboutsummaryrefslogtreecommitdiffstats
path: root/testing/msgsl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/msgsl/APKBUILD')
-rw-r--r--testing/msgsl/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/testing/msgsl/APKBUILD b/testing/msgsl/APKBUILD
deleted file mode 100644
index ae089ff1f56..00000000000
--- a/testing/msgsl/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: Zeyi Shen <qazxdrcssc2006@163.com>
-# Maintainer: Zeyi Shen <qazxdrcssc2006@163.com>
-pkgname=msgsl
-pkgver=3.1.0
-pkgrel=0
-pkgdesc="C++ Guideline Support Library implementation by Microsoft"
-url="https://github.com/microsoft/GSL"
-# These functions don't work on the disabled arches since they cast variables
-# from 'const gsl::byte*' to 'const int*' which increases required alignment of
-# target type and produce a compile error.
-# See: https://github.com/microsoft/GSL/blob/v3.1.0/include/gsl/multi_span#L1670
-arch="all !armhf !armv7 !mips64 !riscv64"
-license="MIT"
-makedepends="cmake gtest"
-source="$pkgname-$pkgver.tar.gz::https://github.com/microsoft/GSL/archive/v$pkgver.tar.gz"
-builddir="$srcdir/GSL-$pkgver"
-
-build() {
- cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=ON
- cmake --build build
-}
-
-check() {
- cd build
- ctest
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-2916df9ee165fc803ffae0a56518f2ba92870e279984913ff591559e1459943c3ffbc1f5a0d819ad8233f0c9034012de3616aa4e10557d87c7285d8425d10696 msgsl-3.1.0.tar.gz
-"