aboutsummaryrefslogtreecommitdiffstats
path: root/testing/muon/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/muon/APKBUILD')
-rw-r--r--testing/muon/APKBUILD78
1 files changed, 49 insertions, 29 deletions
diff --git a/testing/muon/APKBUILD b/testing/muon/APKBUILD
index aee46b9ea88..fcb4b63b0f4 100644
--- a/testing/muon/APKBUILD
+++ b/testing/muon/APKBUILD
@@ -1,44 +1,64 @@
-# Contributor: KikooDX <kikoodx@paranoici.org>
-# Maintainer: KikooDX <kikoodx@paranoici.org>
+# Contributor: Stone Tickle <lattis@mochiro.moe>
+# Maintainer: Stone Tickle <lattis@mochiro.moe>
pkgname=muon
-pkgver=0_git20210812
+pkgver=0.2.0
pkgrel=2
-pkgdesc="meson implementation in C"
-options="!check" # broken test suite
-url="https://sr.ht/~lattis/muon"
-_giturl="https://github.com/annacrombie/muon"
+pkgdesc="A meson-compatible build system."
+url="https://muon.build"
arch="all"
-license="GPL-3.0-only"
+license="GPL-3.0-only AND Apache-2.0"
depends="samurai"
-makedepends="pkgconf-dev curl-dev zlib-dev"
+makedepends="scdoc curl-dev libarchive-dev pkgconf-dev python3 py3-yaml"
subpackages="$pkgname-doc"
-_gitrev=f4ee369d4a90ca597aaf63d99da9355266eba83b
-source="$pkgname-$_gitrev.tar.gz::$_giturl/archive/$_gitrev.tar.gz
- fix-bootstrap.patch"
-builddir="$srcdir/$pkgname-$_gitrev"
-
-prepare() {
- default_prepare
- ./bootstrap.sh bootstrap
-}
+source="
+ $pkgname-$pkgver.tar.gz::https://git.sr.ht/~lattis/muon/archive/$pkgver.tar.gz
+ https://mochiro.moe/wrap/meson-docs-0.64.1-19-g39c6fa4bc.tar.gz
+ fix-tests.patch
+"
+builddir="$srcdir/$pkgname-$pkgver/"
build() {
- bootstrap/muon setup \
- -Dstatic=false \
- -Dcurl=enabled \
- -Dzlib=enabled \
- -Dlibpkgconf=enabled \
- -Dsamu=disabled \
+ mv ../meson-docs subprojects/
+ ./bootstrap.sh build
+ build/muon setup build
+ samu -C build
+
+ # options copied from abuild-meson
+ build/muon setup \
+ -Dprefix=/usr \
+ -Dlibdir=/usr/lib \
+ -Dlibexecdir=/usr/libexec \
+ -Dbindir=/usr/bin \
+ -Dsbindir=/usr/sbin \
+ -Dincludedir=/usr/include \
+ -Ddatadir=/usr/share \
+ -Dmandir=/usr/share/man \
+ -Dinfodir=/usr/share/info \
+ -Dlocaledir=/usr/share/locale \
+ -Dsysconfdir=/etc \
+ -Dlocalstatedir=/var \
+ -Dsharedstatedir=/var/lib \
+ -Dbuildtype=plain \
+ -Dauto_features=auto \
+ -Dwrap_mode=nodownload \
+ -Db_lto=false \
+ -Db_staticpic=true \
+ -Db_pie=true \
build
- ninja -C build
+
+ samu -C build
+}
+
+check() {
+ build/muon -C build test -d dots
}
package() {
- install -Dm711 build/muon "$pkgdir"/usr/bin/muon
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ DESTDIR=$pkgdir build/muon -C build install
}
sha512sums="
-34a76775e137687e345426d3d7dd415fafe5f053d1881b8a2f384ebe49046d9b338c210f3eb1544fddd2dd912427a5d75fb2d8a5be269e3b3e9c95cf5e622e38 muon-f4ee369d4a90ca597aaf63d99da9355266eba83b.tar.gz
-937d8fffec20b5244d7234738eda5baba8a351bff2a6815ec71c30c08180d63febcb6a2adc9a1bd495481d2384cf04c01ab8aa5abc121b76d344a559e4b65569 fix-bootstrap.patch
+b2e90048756bdc26bdea24fe227a87ad4d0e57176e217e22ea492a55229c62e2a70243f60af1e162e2dde8468fdda9662a32ea5cfadd69fab95a83499efa077b muon-0.2.0.tar.gz
+59c986c4c4d545a6488cd74a2b6563b867716b74aab95fd19a745ce46a99fe5222232e132c80c5ed80f3e61d13e74cf2dc13b1b6d4638fd40a69d82d0d74faaa meson-docs-0.64.1-19-g39c6fa4bc.tar.gz
+e9b402583f6dcf31756408abde8eef4752d34c36fcc96b563095eaf73c1736ec06012c347828d5040e18d8b0b788371a5d6fd4866cb4be23b57320ca0df6a74d fix-tests.patch
"